summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-07-23 21:00:22 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-07-24 00:19:18 +0200
commit16f16e2ca8e90fa7ead5176dfde77aac7f179db6 (patch)
treed8369968aa4b165b1c456157d2a321e8ca9d430b /dev-libs/libgdata
parentkde-frameworks/kunitconversion: Restrict broken test (diff)
downloadgentoo-16f16e2ca8e90fa7ead5176dfde77aac7f179db6.tar.gz
gentoo-16f16e2ca8e90fa7ead5176dfde77aac7f179db6.tar.bz2
gentoo-16f16e2ca8e90fa7ead5176dfde77aac7f179db6.zip
dev-libs/libgdata: disable building of demos
Fixes build issues due to automagic GTK+ dependency. Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libgdata')
-rw-r--r--dev-libs/libgdata/files/libgdata-0.17.8-disable-demos.patch60
-rw-r--r--dev-libs/libgdata/libgdata-0.17.8-r1.ebuild67
2 files changed, 127 insertions, 0 deletions
diff --git a/dev-libs/libgdata/files/libgdata-0.17.8-disable-demos.patch b/dev-libs/libgdata/files/libgdata-0.17.8-disable-demos.patch
new file mode 100644
index 000000000000..5221b4e43f2b
--- /dev/null
+++ b/dev-libs/libgdata/files/libgdata-0.17.8-disable-demos.patch
@@ -0,0 +1,60 @@
+From 12fb11f46a7eb4054b74679a6f5ad12dcc41132d Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <g.dartiguelongue@lexfo.fr>
+Date: Sun, 23 Jul 2017 20:46:19 +0200
+Subject: [PATCH] Control build of demos
+
+Building demos is not necessary for distributions. Allow disabling it
+but keep it enabled by default.
+---
+ Makefile.am | 2 ++
+ configure.ac | 7 +++++++
+ 2 files changed, 9 insertions(+)
+
+diff --git a/Makefile.am b/Makefile.am
+index 0e4cf631..8c0c7143 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -635,6 +635,7 @@ endif
+ CODE_COVERAGE_DIRECTORY = $(top_builddir)/gdata
+ CODE_COVERAGE_LCOV_OPTIONS = --base-directory $(abs_top_srcdir)
+
++if ENABLE_BUILD_DEMOS
+ # Demo programs
+ noinst_PROGRAMS = \
+ demos/youtube/youtube-cli \
+@@ -650,6 +651,7 @@ if HAVE_GTK
+ noinst_PROGRAMS += \
+ demos/scrapbook/scrapbook
+ endif
++endif
+
+ demos_docs_list_docs_list_SOURCES = \
+ demos/docs-list/docs-list.c \
+diff --git a/configure.ac b/configure.ac
+index 3b0530c3..1e09f277 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -152,6 +152,10 @@ AC_SUBST([GNOME_PACKAGES_PRIVATE])
+ AC_SUBST([GNOME_PACKAGES])
+ AC_SUBST([GOA_ENABLED])
+
++AC_ARG_ENABLE([build_demos],
++ AS_HELP_STRING([--enable-build-demos],
++ [Enable building demos (default: yes)]),,
++ [enable_build_demos=yes])
+ AC_ARG_ENABLE([always_build_tests],
+ AS_HELP_STRING([--enable-always-build-tests],
+ [Enable always building tests (default: yes)]),,
+@@ -161,6 +165,9 @@ AC_ARG_ENABLE([installed_tests],
+ [Install test programs (default: no)]),,
+ [enable_installed_tests=no])
+
++AM_CONDITIONAL([ENABLE_BUILD_DEMOS],
++ [test "$enable_build_demos" = "yes"])
++
+ AM_CONDITIONAL([ENABLE_ALWAYS_BUILD_TESTS],
+ [test "$enable_always_build_tests" = "yes"])
+ AC_SUBST([ENABLE_ALWAYS_BUILD_TESTS],[$enable_always_build_tests])
+--
+2.13.2
+
diff --git a/dev-libs/libgdata/libgdata-0.17.8-r1.ebuild b/dev-libs/libgdata/libgdata-0.17.8-r1.ebuild
new file mode 100644
index 000000000000..9a28a56d4cd7
--- /dev/null
+++ b/dev-libs/libgdata/libgdata-0.17.8-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2 vala
+
+DESCRIPTION="GLib-based library for accessing online service APIs using the GData protocol"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgdata"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/22" # subslot = libgdata soname version
+
+IUSE="+crypt gnome-online-accounts +introspection static-libs test vala"
+REQUIRED_USE="
+ gnome-online-accounts? ( crypt )
+ vala? ( introspection )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ >=dev-libs/json-glib-0.15
+ >=dev-libs/libxml2-2:2
+ >=net-libs/liboauth-0.9.4
+ >=net-libs/libsoup-2.55.90:2.4[introspection?]
+ >=x11-libs/gdk-pixbuf-2.14:2
+ crypt? ( app-crypt/gcr:= )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.8:= )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.25
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ test? ( >=net-libs/uhttpmock-0.5 )
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-disable-demos.patch
+)
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-build-demos \
+ $(use_enable crypt gnome) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_enable static-libs static) \
+ $(use_enable test always-build-tests)
+}
+
+src_test() {
+ unset ORBIT_SOCKETDIR
+ export GSETTINGS_BACKEND="memory" #486412
+ dbus-launch emake check
+}