summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-04-23 22:29:36 +0300
committerMart Raudsepp <leio@gentoo.org>2018-04-23 22:29:57 +0300
commit8d9df8c94d89750ea6e09bea8b63279c9039d3f5 (patch)
tree4ec6e78d36215aa951ef9c38c6cbe14efe9f7dfc /dev-libs/libgee/libgee-0.20.1.ebuild
parentapp-crypt/libsecret: fix PYTHON_COMPAT - test suite requires python3 (diff)
downloadgentoo-8d9df8c94d89750ea6e09bea8b63279c9039d3f5.tar.gz
gentoo-8d9df8c94d89750ea6e09bea8b63279c9039d3f5.tar.bz2
gentoo-8d9df8c94d89750ea6e09bea8b63279c9039d3f5.zip
dev-libs/libgee: bump to 0.20.1
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libgee/libgee-0.20.1.ebuild')
-rw-r--r--dev-libs/libgee/libgee-0.20.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libgee/libgee-0.20.1.ebuild b/dev-libs/libgee/libgee-0.20.1.ebuild
new file mode 100644
index 000000000000..45ae74459244
--- /dev/null
+++ b/dev-libs/libgee/libgee-0.20.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="GObject-based interfaces and classes for commonly used data structures"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libgee"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.8/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="+introspection"
+
+# FIXME: add doc support, requires valadoc
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection)
+ VALAC="$(type -P false)"
+}