summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-13 03:56:20 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-13 04:09:42 +0200
commitdcf8303a944d767f5a702a5ac0b4db9855d347c3 (patch)
treea87d90ce233fc58b1a6eba874891da4679481dac /dev-libs/libgit2
parentdev-python/yarl: Bump to 1.6.2 (diff)
downloadgentoo-dcf8303a944d767f5a702a5ac0b4db9855d347c3.tar.gz
gentoo-dcf8303a944d767f5a702a5ac0b4db9855d347c3.tar.bz2
gentoo-dcf8303a944d767f5a702a5ac0b4db9855d347c3.zip
dev-libs/libgit2: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libgit2')
-rw-r--r--dev-libs/libgit2/Manifest1
-rw-r--r--dev-libs/libgit2/libgit2-1.1.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/libgit2/Manifest b/dev-libs/libgit2/Manifest
index a527e14c0973..670805a7b739 100644
--- a/dev-libs/libgit2/Manifest
+++ b/dev-libs/libgit2/Manifest
@@ -1 +1,2 @@
DIST libgit2-1.0.1.tar.gz 5312878 BLAKE2B 7eb97bb97d66240ce135e21d348f6dea0c5626992b608f8944b75f9bae5de933fffa07edd536c0353841f8d02c950feec1451008003e35f53554f3c59b069a7f SHA512 7c307822b22e3771e5e908b115600310f7901b3250287532c498003b25a5b1e007bfa23592f16ec4d83c1567a9213710526f78cab7c120316e9a8fc74c5e57a9
+DIST libgit2-1.1.0.tar.gz 5426975 BLAKE2B 2a1c1f71d2a2e06448c78eb46028fdcfd59682dccf2365851c4bd059cdd78842320f9a5ba7345e761611a5b4eba634faf2e26cc669097da0ba2e1c832c23059f SHA512 347bb68900181b44fa58a0417506c91383adb965607fce049a5b4c57ac9cc286e0a140d164c339b50fb6cd6951f47757c2917a2df44ba004bfaa4fb643946bb8
diff --git a/dev-libs/libgit2/libgit2-1.1.0.ebuild b/dev-libs/libgit2/libgit2-1.1.0.ebuild
new file mode 100644
index 000000000000..b9331796cd2a
--- /dev/null
+++ b/dev-libs/libgit2/libgit2-1.1.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit cmake python-any-r1
+
+DESCRIPTION="A linkable library for Git"
+HOMEPAGE="https://libgit2.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${P/_/-}
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0/1.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="examples gssapi libressl +ssh test +threads trace"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/zlib
+ net-libs/http-parser:=
+ gssapi? ( virtual/krb5 )
+ ssh? ( net-libs/libssh2 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ cmake_src_prepare
+ # relying on forked http-parser to support some obscure URI form
+ sed -i -e '/empty_port/s:test:_&:' tests/network/urlparse.c || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_CLAR=$(usex test)
+ -DENABLE_TRACE=$(usex trace ON OFF)
+ -DUSE_GSSAPI=$(usex gssapi ON OFF)
+ -DUSE_SSH=$(usex ssh)
+ -DTHREADSAFE=$(usex threads)
+ -DUSE_HTTP_PARSER=system
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]] ; then
+ # repo::iterator::fs_preserves_error fails if run as root
+ # since root can still access dirs with 0000 perms
+ ewarn "Skipping tests: non-root privileges are required for all tests to pass"
+ else
+ local TEST_VERBOSE=1
+ cmake_src_test -R offline
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ dodoc docs/*.{md,txt}
+
+ if use examples ; then
+ find examples -name '.gitignore' -delete || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}