summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-15 22:47:46 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-16 00:43:10 +0200
commit70f8908e942bc16317033c294185361aff679d58 (patch)
treeb6ccf1d59f5ee551a3f622bad2afb61831f9dcd6 /dev-libs/libgweather
parentgnome-base/libgtop: version bump 2.34.2 → 2.36.0 (diff)
downloadgentoo-70f8908e942bc16317033c294185361aff679d58.tar.gz
gentoo-70f8908e942bc16317033c294185361aff679d58.tar.bz2
gentoo-70f8908e942bc16317033c294185361aff679d58.zip
dev-libs/libgweather: version bump 3.20.4 → 3.24.1
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/Manifest1
-rw-r--r--dev-libs/libgweather/libgweather-3.24.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libgweather/Manifest b/dev-libs/libgweather/Manifest
index 69630b6e3cf9..34e2c7bc1a13 100644
--- a/dev-libs/libgweather/Manifest
+++ b/dev-libs/libgweather/Manifest
@@ -1 +1,2 @@
DIST libgweather-3.20.4.tar.xz 3342220 SHA256 7dcdc555c48461d07a198bc44e0e6ed39105d8513b12fa97c4590f5b2d912fc2 SHA512 65b28a2bf8e9e7d8b02972d1d2f701ac8668b1e91154ba7ee94e9a08bb98d28ce44e88842e2fe78a13ce9f942d79fd2950d8de266dae28bb262c5fc11328ada9 WHIRLPOOL f01170d5e7790c22b1bfba8b6cd0e7b90708a818be2dc12a698e5ab4babb3efb6dfc368d7538b546a893a1b17b11ed04ebb0050c62b368f8f354ad9102b3c6e8
+DIST libgweather-3.24.1.tar.xz 3350680 SHA256 1227316037b63dac4153031a22abccb3d2ac679a7409e29cd303eec499eb653c SHA512 564464d7a18a8e0320871ea418b1163163941c950c5acea5ee65a087e44c4d81e019e2e3e4cb6751989f823cbb7c5691713d3dcef72aeaf6ff264e61b6f7b4b4 WHIRLPOOL 82ac37983c7c8f683b958d005f35b6eef72f5bffdfeebaca4ae903f41816d8fd3f1da6a162689b4880c05739d7d2a1238ff1277dd7694d857087b4c5a488c71f
diff --git a/dev-libs/libgweather/libgweather-3.24.1.ebuild b/dev-libs/libgweather/libgweather-3.24.1.ebuild
new file mode 100644
index 000000000000..b746855aad33
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-3.24.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-6" # subslot = 3-(libgweather-3 soname suffix)
+
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+COMMON_DEPEND="
+ >=x11-libs/gtk+-3.13.5:3[introspection?]
+ >=dev-libs/glib-2.35.1:2
+ >=net-libs/libsoup-2.44:2.4
+ >=dev-libs/libxml2-2.6.0:2
+ sci-geosciences/geocode-glib
+ >=sys-libs/timezone-data-2010k
+
+ glade? ( >=dev-util/glade-3.16:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-applets-2.22.0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.11
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}