summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-07-17 23:23:01 +0300
committerMart Raudsepp <leio@gentoo.org>2020-07-17 23:23:31 +0300
commite1a86bc5a5951122a447080bba8f502da5535216 (patch)
tree05b67ff81c8e1afdf3ca08e2958ca4d2613e7fa6 /dev-libs/libgweather
parentgnome-base/gdm: bump to 3.36.3 (diff)
downloadgentoo-e1a86bc5a5951122a447080bba8f502da5535216.tar.gz
gentoo-e1a86bc5a5951122a447080bba8f502da5535216.tar.bz2
gentoo-e1a86bc5a5951122a447080bba8f502da5535216.zip
dev-libs/libgweather: bump to 3.36.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/Manifest1
-rw-r--r--dev-libs/libgweather/libgweather-3.36.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/libgweather/Manifest b/dev-libs/libgweather/Manifest
index d4a1b0318377..b1a7187450fb 100644
--- a/dev-libs/libgweather/Manifest
+++ b/dev-libs/libgweather/Manifest
@@ -1 +1,2 @@
DIST libgweather-3.34.0.tar.xz 2725096 BLAKE2B af1034b905354aed433e3a5249305718b850f84dabcf3e96b9f9bcdda7dd78258ede0a9e82cab9b9d7f1b63d8e1a61bc3c83c1c18ec38790bc43c29fe98bb89d SHA512 44451837039965251d86f6f538c943a771ab1944d9190ddb2c6bdb34b3ed0e33756c537e84f24487fd5f28b107e8d3af05a6c20a68f83734ac26ff69a8bd0aba
+DIST libgweather-3.36.1.tar.xz 2702144 BLAKE2B bd867461b64ef81607695ae1a3796d2b096129a9a60721c5fcb20d8c35859c0b76a985e9393c23b311f7c0fdec3e691618eab83a826b483c427287906d575251 SHA512 6c7090b0b6dfac61e73a398d34329cd706080a007694ceb3d47700b4f444982f8ca989dd6dfaefe85b79ffd5af9c423be4bf1bd8491ac0ba6bd15c150d97b26d
diff --git a/dev-libs/libgweather/libgweather-3.36.1.ebuild b/dev-libs/libgweather/libgweather-3.36.1.ebuild
new file mode 100644
index 000000000000..f3d82c03f4cb
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-3.36.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Location and timezone database and weather-lookup library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-16-2" # subslot = 3-(libgweather-3 soname suffix) w/ temporary -2 suffix for silent ABI break after 3.28 without soname bump as per distro-list
+
+IUSE="glade gtk-doc +introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=x11-libs/gtk+-3.13.5:3[introspection?]
+ >=net-libs/libsoup-2.44:2.4
+ >=dev-libs/libxml2-2.6.0:2
+ sci-geosciences/geocode-glib
+ >=sys-libs/timezone-data-2010k
+
+ glade? ( >=dev-util/glade-3.16:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.11
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+PATCHES=(
+ "${FILESDIR}"/3.32.1-meson-tweaks.patch # Provide introspection optionality and don't build tests that aren't ran automatically
+)
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use glade glade_catalog)
+ $(meson_use vala enable_vala)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}