summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-11 08:16:09 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-11 08:16:30 +0100
commitbb918c70ac7d1dae5df74af42e033ef0f5eadd69 (patch)
treecc2111135b31337ba6a0f9bcce971926cd25faaf /dev-libs/libical/libical-2.0.0-r2.ebuild
parentdev-perl/DateTime: Bump to 1.280.0 (diff)
downloadgentoo-bb918c70ac7d1dae5df74af42e033ef0f5eadd69.tar.gz
gentoo-bb918c70ac7d1dae5df74af42e033ef0f5eadd69.tar.bz2
gentoo-bb918c70ac7d1dae5df74af42e033ef0f5eadd69.zip
dev-libs/libical: Revbump to add dev-libs/icu to RDEPEND (bug #599246).
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-libs/libical/libical-2.0.0-r2.ebuild')
-rw-r--r--dev-libs/libical/libical-2.0.0-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libical/libical-2.0.0-r2.ebuild b/dev-libs/libical/libical-2.0.0-r2.ebuild
new file mode 100644
index 000000000000..72c6aca587e1
--- /dev/null
+++ b/dev-libs/libical/libical-2.0.0-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="An implementation of basic iCAL protocols"
+HOMEPAGE="https://github.com/libical/libical"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.0 LGPL-2.1 )"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc examples static-libs"
+
+# The GOBJECT_INTROSPECTION build is broken, and upstream has given up
+# on it at the moment (it's disabled in Travis). It will probably come
+# back in v2.0.1 or later.
+# This snippet belongs to RDEPEND:
+# introspection? ( dev-libs/gobject-introspection )"
+RDEPEND="dev-libs/icu:="
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+DOCS=(
+ AUTHORS ReadMe.txt ReleaseNotes.txt TEST THANKS TODO
+ doc/{AddingOrModifyingComponents,UsingLibical}.txt
+)
+
+PATCHES=( "${FILESDIR}/fix-libdir-location.patch" )
+
+src_configure() {
+ # See above, introspection is disabled for v2.0.0 at least.
+ #local mycmakeargs=(
+ # -DGOBJECT_INTROSPECTION=$(usex introspection true false)
+ #)
+ use static-libs || mycmakeargs+=( -DSHARED_ONLY=ON )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use examples; then
+ rm examples/CMakeLists.txt || die
+ dodoc -r examples
+ fi
+}