summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-01-20 18:29:03 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-01-20 18:29:03 +0100
commit388939a8feb055caf4d274851f63bb7ea60dd02b (patch)
tree45e81d3241b771c4ae427ce0b6d3fb0c2bc30824 /dev-libs/libinput
parentapp-emulation/qemu: drop USE=uuid in newer versions #606506 (diff)
downloadgentoo-388939a8feb055caf4d274851f63bb7ea60dd02b.tar.gz
gentoo-388939a8feb055caf4d274851f63bb7ea60dd02b.tar.bz2
gentoo-388939a8feb055caf4d274851f63bb7ea60dd02b.zip
dev-libs/libinput: Version bump to 1.6.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.6.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 717a497f1d29..486b3a5ae903 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -5,3 +5,4 @@ DIST libinput-1.4.2.tar.xz 900776 SHA256 8c38826a785594811bef6a9daadbfa2e172e3f0
DIST libinput-1.5.2.tar.xz 926048 SHA256 ba26e2bc64ed551eaef193178ed06b07b97a09ac6f4e442f5f15bbc3f3174682 SHA512 a3552f36fc91b523caceb128d048a0a7161335aef78554f202011fcc9acfb5f772d2124a4441f0f542f1b8051b8a2ecb7b00fad5456d8c06b213b96b9ebc91de WHIRLPOOL 025cd1b3261a977b2a579e03766939a443b6fa26b486e9fa16e445b39acf5d31b1f74260670b74718e5d11648c459b42b546e2311d5cac8a713a8a5b0e893791
DIST libinput-1.5.3.tar.xz 928852 SHA256 91206c523b4e7aeecf296d0b94276c61bea90b9260d198c8ee3a91eced10a6e3 SHA512 4d5ca9189275d6f2ed40ff85903bf10ae3b15ceaea43a3565384b6495a9b1764fed1f95c667dfa9e96170b3709a9c8dc1d1bad88cb82d0de69045b7c5f0bc7e6 WHIRLPOOL 548f08f755abf0c01c42a4e21abdcd4068b16dd57d37035922c390f17a9cfba52f56aab1dfb693ed13666a9d94cffef38cb4c7c7d030e9898c1bfdb3fb54d501
DIST libinput-1.5.4.tar.xz 927448 SHA256 6f9ad1ede468bd54ec4469b8a4eb93a6f62f7fe6480c7a43e36c5d58cc2822b7 SHA512 114f436806fd27ece2b19577eefd3f6299cc88612f8437fd07ba1862c0bf4347ac5cc09fad9f798a5e242abd176cfb271fa52af04b0ef88da3210a96fd57a086 WHIRLPOOL d7c2ffd8212c4808641b65f553ea6c1553188a30279f8e3491767a8ba159d42dbd30a0cebc3a727542a83cf216c17d1b5f1504dc8fbb4f7b5664aac35b8032dc
+DIST libinput-1.6.0.tar.xz 927656 SHA256 b7534f518d735c643aedca2fb4694683dfddc8d0600cfb628c87a18e65255832 SHA512 0e52f70fc5b1aa1e9c0621770ba2530f1652611aff1a557ac8083559e22293942d7c468f9bafe9e97e4f71e71df6f3828f9949d8897bea26982045340e3edc92 WHIRLPOOL b41858d727eb27dbcd4025212731fe93e3970f7d36e8654bc5b121b3a6a3d6c1ca6117750d02b54db908d118d1b84a0eec5581b88a517635ffece5fb1378dae2
diff --git a/dev-libs/libinput/libinput-1.6.0.ebuild b/dev-libs/libinput/libinput-1.6.0.ebuild
new file mode 100644
index 000000000000..4a42b03e9e4a
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.6.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.12 )
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_prepare() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable input_devices_wacom libwacom) \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}