summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-23 02:42:57 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-23 02:42:57 +0200
commit4c894654b1421737c7b42c973fdbf6c8e15b07dd (patch)
tree8e313ac2bea45d0936c0c310a637113117519e11 /dev-libs/libinput
parentdev-libs/libbytesize: Bump to version 1.3 (diff)
downloadgentoo-4c894654b1421737c7b42c973fdbf6c8e15b07dd.tar.gz
gentoo-4c894654b1421737c7b42c973fdbf6c8e15b07dd.tar.bz2
gentoo-4c894654b1421737c7b42c973fdbf6c8e15b07dd.zip
dev-libs/libinput: Bump to version 1.10.5
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.10.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index d7de5493d7c6..265df39ab00d 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,5 +1,6 @@
DIST libinput-1.10.3.tar.xz 493216 BLAKE2B 0646575d619c42bfc2b54018e4ee08e43c939e2bf8ce2fd111a113dce4acef73dddfb453a083a53964b70bb0e15a619c1a00b63c87b2cf231190b184b82622f7 SHA512 4c73673e138a7aff9d6f2d189b8afdfb51c868eca0487c8c487ffd3bb48849994a9095fbd4c5c725ee17fafc2a85298106e0cc7b59b4a8cd13ec28f65d15c01d
DIST libinput-1.10.4.tar.xz 493152 BLAKE2B 84f49f523fc2fb4c306212a28ccf2c02650898ee5ac6956522aa9a13d46f0ddffbfac94fb11205caf3e172ef652d7339902831993ef37c0ad4e3e9ef1cc6eaf3 SHA512 b6f24f135e2396d53c0576a3b3887cd3736f2209fc448c6419cd1f1d7ee6aedff8e067f4b780f50ada5a4418d5bc47a4010cb328f366ee7fd1a2dba1ffc96c38
+DIST libinput-1.10.5.tar.xz 497496 BLAKE2B c716bdd2620c044c7776f53fd368dc2e1e77374cb46a1d395fa704d1c823776c257867b9180952cea13668cbfd1aebda1780b91544d33623dda8dbe86f041b2f SHA512 61f19ea777b523f0e76869b8e7dbbff5e51132d3c856c6edb9915a695f7903256228e71be2567642866923a800f1283bdd5aff97266ac26c2e42dfce0bffa50b
DIST libinput-1.7.3.tar.xz 922464 BLAKE2B fa38675905af55931676c22d9e4d56befbb055fba56ba13c61a1917050bc1eb62bcfe1d078b478047006d4c0d06d83186d0d6739cbf9dc49acce487ccb0b7e3a SHA512 2262dc56d213a4d3ea765e870af200e2c336a166baa1bbdf5205e3ce70faefc777429ba09563c5dd79feb5442f53abc84e04a0f32a06bb622d6e120bb8ad152b
DIST libinput-1.8.3.tar.xz 941832 BLAKE2B cf6464d68387cca23d0f70eaceeec8b453c53f1cac22892722d48983788b43a136617c62ad39c8d435bbf07c0cb9cd720250ea91e31f10526acd5147b1d78237 SHA512 88006d217e3507858fa6b9ac1f25c267255fb51d1bcf1208d2afd423bf2a9292944bc5526ea91f27fad3ff04c2f9f43ab3aa25fd9fb7ace1231ecd33ddf18de6
DIST libinput-1.9.4.tar.xz 472636 BLAKE2B 692a23047cb0b54d14763b34ce3ce1414101d0097dce10d237ec32a67f29c31cbf2928681084f7561e072e555c932f0e3bc54cfb0ecbcdd0d823426806e357b6 SHA512 302f9497ea9ffb2163c643e9ca2f0a773ea141f6fe0a3aa3d8e86eb11a5d11e75d858b1e679ebfd3f913c645beac059cfd356b37c4ea17a8853068f79a740a4b
diff --git a/dev-libs/libinput/libinput-1.10.5.ebuild b/dev-libs/libinput/libinput-1.10.5.ebuild
new file mode 100644
index 000000000000..5364b191c2fc
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.10.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit meson udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ -Ddocumentation="$(usex doc true false)"
+ -Dlibwacom="$(usex input_devices_wacom true false)"
+ -Dtests="$(usex test true false)"
+ -Dudev-dir="$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/html/.
+ fi
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}