summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libisofs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libisofs')
-rw-r--r--dev-libs/libisofs/Manifest2
-rw-r--r--dev-libs/libisofs/libisofs-1.3.8.ebuild42
-rw-r--r--dev-libs/libisofs/libisofs-1.4.0.ebuild42
-rw-r--r--dev-libs/libisofs/metadata.xml12
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-libs/libisofs/Manifest b/dev-libs/libisofs/Manifest
new file mode 100644
index 000000000000..6ba531ed3da0
--- /dev/null
+++ b/dev-libs/libisofs/Manifest
@@ -0,0 +1,2 @@
+DIST libisofs-1.3.8.tar.gz 802154 SHA256 acd7bf42d5d1d5c277f4aad46e5b96229045a38a0fb7d43cfd7841ee3268fda5 SHA512 7e078a4070741d975234ac10ed6cd2a0366724e9fa440e7063c64f91a60c9454c6828e2b7737d6105f36067008495bfcba8327e56892ccb0962027dc78e251ce WHIRLPOOL 660f2cba77e8b83306fe4d40e34f0e94ecc18a8defd0375cadc84c0d964d6c868b2965329e51e3b5139c88e7cb20ee78f817004cb141e8be5528aa00a25d5647
+DIST libisofs-1.4.0.tar.gz 817349 SHA256 6e62824d879ffe85c0e4363677fd10f177a4c85af049d0861c70bf442b901fce SHA512 894976bc432f429d4a9fd4d92ba51d042b4944991c5ff01edc4cae5753f5fb73a4e4f147284974e4233c5b5fb1137c989d60ea349a4d8be7a237fd82530d3f36 WHIRLPOOL 378fb62befe4c929932386ee6b1a91d1b90f3de41abc65e7335a9015021aa0e49fddb1b0d46166087ae5b3719b2324163335233ac80a3da94f1fe2612d695c77
diff --git a/dev-libs/libisofs/libisofs-1.3.8.ebuild b/dev-libs/libisofs/libisofs-1.3.8.ebuild
new file mode 100644
index 000000000000..bf9f02d3f91a
--- /dev/null
+++ b/dev-libs/libisofs/libisofs-1.3.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="libisofs is an open-source library for reading, mastering and writing optical discs"
+HOMEPAGE="http://libburnia-project.org/"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="acl debug static-libs verbose-debug xattr zlib"
+
+RDEPEND="acl? ( virtual/acl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ $(use_enable verbose-debug) \
+ $(use_enable acl libacl) \
+ $(use_enable xattr) \
+ $(use_enable zlib) \
+ --disable-libjte \
+ --disable-ldconfig-at-install
+}
+
+src_install() {
+ default
+
+ dodoc Roadmap doc/{*.txt,Tutorial}
+
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libisofs/libisofs-1.4.0.ebuild b/dev-libs/libisofs/libisofs-1.4.0.ebuild
new file mode 100644
index 000000000000..b0e0e418161d
--- /dev/null
+++ b/dev-libs/libisofs/libisofs-1.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="libisofs is an open-source library for reading, mastering and writing optical discs"
+HOMEPAGE="http://libburnia-project.org/"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="acl debug static-libs verbose-debug xattr zlib"
+
+RDEPEND="acl? ( virtual/acl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ $(use_enable verbose-debug) \
+ $(use_enable acl libacl) \
+ $(use_enable xattr) \
+ $(use_enable zlib) \
+ --disable-libjte \
+ --disable-ldconfig-at-install
+}
+
+src_install() {
+ default
+
+ dodoc Roadmap doc/{*.txt,Tutorial}
+
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libisofs/metadata.xml b/dev-libs/libisofs/metadata.xml
new file mode 100644
index 000000000000..7562711d5e18
--- /dev/null
+++ b/dev-libs/libisofs/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-optical</herd>
+<maintainer>
+<email>billie@gentoo.org</email>
+<name>Daniel Pielmeier</name>
+</maintainer>
+<use>
+<flag name='verbose-debug'>Enable verbose debug messages</flag>
+</use>
+</pkgmetadata>