summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@mobilityhouse.com>2017-12-03 13:49:22 +0100
committerMichael Palimaka <kensington@gentoo.org>2017-12-07 21:29:39 +1100
commit5799c21d2de1f44ef8de29a200692b852cbe67e8 (patch)
tree3a82d0587d3b74bddc9fcf17748cfc9eebb73a4f /dev-libs/libite/libite-2.0.0.ebuild
parentdev-libs/libuev: Simple event loop for Linux (diff)
downloadgentoo-5799c21d2de1f44ef8de29a200692b852cbe67e8.tar.gz
gentoo-5799c21d2de1f44ef8de29a200692b852cbe67e8.tar.bz2
gentoo-5799c21d2de1f44ef8de29a200692b852cbe67e8.zip
dev-libs/libite: a collection of useful BSD API
Libite is a lightweight library of frog DNA. It can be used to fill the gaps in any dinosaur project. It holds useful functions and macros developed by both Finit and the OpenBSD project. Most notably the string functions: strlcpy(3), strlcat(3) and the highly useful *BSD sys/queue.h and sys/tree.h API's. Closes: https://bugs.gentoo.org/639626 Closes: https://github.com/gentoo/gentoo/pull/6421 Package-Manager: Portage-2.3.13, Repoman-2.3.1
Diffstat (limited to 'dev-libs/libite/libite-2.0.0.ebuild')
-rw-r--r--dev-libs/libite/libite-2.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/libite/libite-2.0.0.ebuild b/dev-libs/libite/libite-2.0.0.ebuild
new file mode 100644
index 000000000000..4dff1da74a46
--- /dev/null
+++ b/dev-libs/libite/libite-2.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A collection of useful BSD APIs"
+HOMEPAGE="https://github.com/troglobit/libite"
+SRC_URI="https://github.com/troglobit/libite/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure(){
+ econf --enable-static=$(usex static-libs)
+}
+
+src_install(){
+ default
+ find "${D}" -name '*.la' -delete || die
+ rm "${D}/usr/share/doc/${PF}/LICENSE" || die
+}