summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libixion/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libixion/files')
-rw-r--r--dev-libs/libixion/files/libixion-0.9.1-python-optional.patch56
-rw-r--r--dev-libs/libixion/files/libixion-0.9.1-typo.patch18
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch b/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch
new file mode 100644
index 000000000000..a4e7239568a2
--- /dev/null
+++ b/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch
@@ -0,0 +1,56 @@
+commit 59c360c9fe438a2805d65decc6c7889bc99a7747
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun May 31 10:14:17 2015 +0200
+
+ python: Make it optional
+
+ python bindings are built unless disabled
+
+diff --git a/configure.ac b/configure.ac
+index 03f6120..1c7d8b2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,7 +15,6 @@ AC_PREREQ([2.63])
+ AC_INIT([libixion], [ixion_version])
+ AC_CONFIG_HEADERS([config.h])
+ AM_INIT_AUTOMAKE([1.11 foreign dist-bzip2 dist-xz])
+-AM_PATH_PYTHON(2.7.0)
+ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+ AC_ARG_WITH(hash-container-compat,
+@@ -28,6 +27,9 @@ AC_ARG_WITH(mdds-include-path,
+ AS_HELP_STRING([--with-mdds-include-path], [specify include path for mdds headers.])
+ ,)
+
++AC_ARG_ENABLE([python],
++ AS_HELP_STRING([--disable-python], [Disable python bindings]))
++
+ IXION_API_VERSION=ixion_api_version
+ IXION_MAJOR_VERSION=ixion_major_version
+ IXION_MINOR_VERSION=ixion_minor_version
+@@ -82,7 +84,11 @@ fi
+ PKG_CHECK_MODULES([MDDS],[mdds >= 0.12.0])
+
+ # Check for python.
+-PKG_CHECK_MODULES([PYTHON], [python >= 0.27.1])
++AS_IF([test "x$enable_python" != "xno"], [
++ AM_PATH_PYTHON(2.7.0)
++ PKG_CHECK_MODULES([PYTHON], [python >= 0.27.1])
++])
++AM_CONDITIONAL([PYTHON], [test "x$enable_python" != "xno"])
+
+ CPPFLAGS="$CPPFLAGS -g -Os -fvisibility=hidden"
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 6e138a4..cd912ab 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,4 +1,7 @@
+-SUBDIRS = libixion python
++SUBDIRS = libixion
++if PYTHON
++ SUBDIRS += python
++endif
+
+ AM_CPPFLAGS = -I$(top_srcdir)/include $(MDDS_CFLAGS)
+
diff --git a/dev-libs/libixion/files/libixion-0.9.1-typo.patch b/dev-libs/libixion/files/libixion-0.9.1-typo.patch
new file mode 100644
index 000000000000..7e41f7bb752f
--- /dev/null
+++ b/dev-libs/libixion/files/libixion-0.9.1-typo.patch
@@ -0,0 +1,18 @@
+commit ceddf45ed98dd0b65b510a284d373630c7642587
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun May 31 11:55:08 2015 +0200
+
+ src/Makefile.am: Fix typo
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index ee9a1cc..b28c610 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -28,6 +28,6 @@ ixion_sorter_SOURCES = \
+ ixion_sorter_LDADD = libixion/libixion-@IXION_API_VERSION@.la \
+ $(BOOST_THREAD_LIBS) $(BOOST_PROGRAM_OPTIONS_LIBS)
+
+-AM_TESTS_ENVIRONMENT = PATH=.libs$${PATH:+:$${PATH}}; epxort PATH; \
++AM_TESTS_ENVIRONMENT = PATH=.libs$${PATH:+:$${PATH}}; export PATH; \
+ LD_LIBRARY_PATH=libixion/.libs$${LD_LIBRARY_PATH:+:$${LD_LIBRARY_PATH}}; export LD_LIBRARY_PATH;
+ TESTS = ../test/ixion-parser-test.sh