summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-09-24 21:15:26 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-10-02 00:08:34 +0200
commit27dd01e371adb4e689b203def9e1df9a3a72ce57 (patch)
tree34ad467ae213ffc68414d6dd2df7ba93c8465f68 /dev-libs/libixion/libixion-9999.ebuild
parentapp-text/libetonyek: Fix configure with mdds-1.2 (diff)
downloadgentoo-27dd01e371adb4e689b203def9e1df9a3a72ce57.tar.gz
gentoo-27dd01e371adb4e689b203def9e1df9a3a72ce57.tar.bz2
gentoo-27dd01e371adb4e689b203def9e1df9a3a72ce57.zip
dev-libs/libixion: Version bump to 0.12.1
Adding USE=debug,threads, dropping boost[threads] build dep Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/libixion/libixion-9999.ebuild')
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index 62cd38058ae5..9fd47304f9fb 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
-PYTHON_COMPAT=( python{3_3,3_4,3_5} )
+PYTHON_COMPAT=( python3_{4,5} )
[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
inherit eutils python-single-r1 ${GITECLASS}
@@ -17,13 +17,13 @@ HOMEPAGE="https://gitlab.com/ixion/ixion"
[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/ixion/src/${P}.tar.xz"
LICENSE="MIT"
-SLOT="0/0.11" # based on SONAME of libixion.so
+SLOT="0/0.12" # based on SONAME of libixion.so
[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="python static-libs"
+IUSE="debug python static-libs +threads"
RDEPEND="
- dev-libs/boost:=[threads]
+ dev-libs/boost:=
python? ( ${PYTHON_DEPS} )
"
DEPEND="${RDEPEND}
@@ -37,14 +37,16 @@ pkg_setup() {
}
src_prepare() {
- eapply_user
+ default
[[ ${PV} == 9999 ]] && eautoreconf
}
src_configure() {
econf \
+ $(use_enable debug) \
$(use_enable python) \
- $(use_enable static-libs static)
+ $(use_enable static-libs static) \
+ $(use_enable threads)
}
src_install() {