summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/liblist/liblist-2.3.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/liblist/liblist-2.3.1-r1.ebuild')
-rw-r--r--dev-libs/liblist/liblist-2.3.1-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/liblist/liblist-2.3.1-r1.ebuild b/dev-libs/liblist/liblist-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..2a4f7ab8d037
--- /dev/null
+++ b/dev-libs/liblist/liblist-2.3.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit multilib
+
+DESCRIPTION="This package provides generic linked-list manipulation routines, plus queues and stacks"
+HOMEPAGE="http://ohnopub.net/liblist"
+SRC_URI="ftp://ohnopublishing.net/mirror/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux"
+IUSE="doc examples static-libs"
+
+DEPEND="doc? ( media-gfx/transfig
+ dev-texlive/texlive-metapost
+ virtual/latex-base )"
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable doc docs) \
+ $(use_enable examples) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc README || die
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/{*.c,Makefile,README} || die
+ insinto /usr/share/doc/${PF}/examples/cache
+ doins examples/cache/{*.c,README} || die
+ fi
+
+ if ! use static-libs; then
+ rm -v "${ED}"/usr/$(get_libdir)/liblist.la || die
+ if use examples; then
+ rm -v "${ED}"/usr/$(get_libdir)/libcache.la || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ elog "Note the man pages for this package have been renamed to avoid"
+ elog "name collisions with some system functions, however, the libs"
+ elog "and header files have not been changed."
+ elog "The new names are llist, lcache, lqueue, and lstack."
+}