summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/liblogging
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/liblogging')
-rw-r--r--dev-libs/liblogging/Manifest3
-rw-r--r--dev-libs/liblogging/liblogging-1.0.2.ebuild39
-rw-r--r--dev-libs/liblogging/liblogging-1.0.4.ebuild36
-rw-r--r--dev-libs/liblogging/liblogging-1.0.5.ebuild36
-rw-r--r--dev-libs/liblogging/metadata.xml23
5 files changed, 137 insertions, 0 deletions
diff --git a/dev-libs/liblogging/Manifest b/dev-libs/liblogging/Manifest
new file mode 100644
index 000000000000..e3f3a80842ec
--- /dev/null
+++ b/dev-libs/liblogging/Manifest
@@ -0,0 +1,3 @@
+DIST liblogging-1.0.2.tar.gz 285555 SHA256 bcadd9fc0253ee096df965d8d46bc3f27a95f4885d66e55e495e5dfddb16b0dd SHA512 bd2a78110f080e0531388bac372e5dac2c7f10973e59bc3c702d3c9ae3a5d21ae021df00b53092fabcbbde20f1eba108b22ea81156c2fcb6bc2053531385b9f9 WHIRLPOOL da2a6963e93527ea0d30fbffb5d9971cd62b36871d488a88b500848a7920b0416415480e2002529f7fa51d730f0f5a30946a34af4628eefb69dcc82349620731
+DIST liblogging-1.0.4.tar.gz 565078 SHA256 aceb5d2aa8bdc771ff66f407f9adf4176b654db63e34a8605795b68be537b81c SHA512 7d57a4d5d41ab2033dd57370c4511749f7965949a30eacaf36e7608acc64a32c42903dc1b5bb50c649dcb9a5ed91a2f0339d21aa0fc20a6a6144616dae556ccf WHIRLPOOL 76f9ba9ed7b8b7a050a29ca1be8e723c0b99f774416dd514b74b792bafafadd677533f38d77577b75ec6267b1025810a5262b763223c55a983efbf39a3f19085
+DIST liblogging-1.0.5.tar.gz 571051 SHA256 310dc1691279b7a669d383581fe4b0babdc7bf75c9b54a24e51e60428624890b SHA512 fd0c89b670bdf4d257d6a31b18b44940ba2edae84633ead6577f164e1ded93709445c35027a28f6e7fda4c984964c3446978eaf0abf843e31ecc11b979e2adde WHIRLPOOL 17c22802e9037aee69c6985a627b6eb24281311292543bc4d9e0383290f7181bcf959de07405a5783f09e8d3dcfb2c88ae5701cec97a3812815f40c6a36ea715
diff --git a/dev-libs/liblogging/liblogging-1.0.2.ebuild b/dev-libs/liblogging/liblogging-1.0.2.ebuild
new file mode 100644
index 000000000000..170146bbe784
--- /dev/null
+++ b/dev-libs/liblogging/liblogging-1.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Liblogging is an easy to use, portable, open source library for system logging"
+HOMEPAGE="http://www.liblogging.org"
+SRC_URI="https://github.com/rsyslog/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE="rfc3195 static-libs +stdlog systemd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/docutils
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog )
+
+src_prepare() {
+ sed -i -e 's|rst2man|rst2man.py|g' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable rfc3195)
+ $(use_enable stdlog)
+ $(use_enable systemd journal)
+ )
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/liblogging/liblogging-1.0.4.ebuild b/dev-libs/liblogging/liblogging-1.0.4.ebuild
new file mode 100644
index 000000000000..fa93a5971868
--- /dev/null
+++ b/dev-libs/liblogging/liblogging-1.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Liblogging is an easy to use, portable, open source library for system logging"
+HOMEPAGE="http://www.liblogging.org"
+SRC_URI="http://download.rsyslog.com/liblogging/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/0"
+KEYWORDS="amd64 ~arm hppa x86"
+IUSE="rfc3195 static-libs +stdlog systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable rfc3195)
+ $(use_enable stdlog)
+ $(use_enable systemd journal)
+ )
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/liblogging/liblogging-1.0.5.ebuild b/dev-libs/liblogging/liblogging-1.0.5.ebuild
new file mode 100644
index 000000000000..431fe6f5f73b
--- /dev/null
+++ b/dev-libs/liblogging/liblogging-1.0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Liblogging is an easy to use, portable, open source library for system logging"
+HOMEPAGE="http://www.liblogging.org"
+SRC_URI="http://download.rsyslog.com/liblogging/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE="rfc3195 static-libs +stdlog systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable rfc3195)
+ $(use_enable stdlog)
+ $(use_enable systemd journal)
+ )
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/liblogging/metadata.xml b/dev-libs/liblogging/metadata.xml
new file mode 100644
index 000000000000..38eb6acc140f
--- /dev/null
+++ b/dev-libs/liblogging/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>ultrabug@gentoo.org</email>
+ <name>Ultrabug</name>
+ </maintainer>
+ <maintainer>
+ <email>whissi@whissi.de</email>
+ <name>Thomas D. (Whissi)</name>
+ <description>Proxy-Maintainer, CC. bugs</description>
+ </maintainer>
+ <use>
+ <flag name="rfc3195">
+ Enables RFC 3195 protocol (aka syslog-reliable) support.
+ If you don't know what this is, you don't need it!
+ </flag>
+ <flag name="stdlog">
+ Enables liblogging's core component (think of it as a the next version of the syslog(3) API).
+ </flag>
+ </use>
+</pkgmetadata>