summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libmelf/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libmelf/files')
-rw-r--r--dev-libs/libmelf/files/libmelf-0.4.0-gcc-makefile-cleanup.patch129
-rw-r--r--dev-libs/libmelf/files/libmelf-0.4.0-r1-gcc-makefile-cleanup.patch105
-rw-r--r--dev-libs/libmelf/files/libmelf-0.4.1-unfinal-release.patch145
3 files changed, 379 insertions, 0 deletions
diff --git a/dev-libs/libmelf/files/libmelf-0.4.0-gcc-makefile-cleanup.patch b/dev-libs/libmelf/files/libmelf-0.4.0-gcc-makefile-cleanup.patch
new file mode 100644
index 000000000000..ddf7c8a1ca03
--- /dev/null
+++ b/dev-libs/libmelf/files/libmelf-0.4.0-gcc-makefile-cleanup.patch
@@ -0,0 +1,129 @@
+diff -Nuar --exclude '*~' libmelf-0.4.0.orig/example/Makefile.in libmelf-0.4.0/example/Makefile.in
+--- libmelf-0.4.0.orig/example/Makefile.in 2003-03-24 00:48:22.000000000 -0800
++++ libmelf-0.4.0/example/Makefile.in 2010-05-31 19:56:43.546947560 -0700
+@@ -1,7 +1,13 @@
+ cc=@CC@
+ DEFINES=@DEFINES@
++OPTFLAGS=-Wall -O3
++CFLAGS=${DEFINES} ${OPTFLAGS} -I..
++BINS = sign test new
+
+-all:
+- ${CC} ${DEFINES} -I.. -Wall -O3 sign.c -o sign ../libmelf.a
+- ${CC} ${DEFINES} -I.. -Wall -O3 test.c -o test ../libmelf.a
+- ${CC} ${DEFINES} -I.. -Wall -O3 new.c -o new ../libmelf.a
++%: %.c
++ ${CC} $(CFLAGS) $^ -o $@ -L.. -lmelf
++
++all: $(BINS)
++
++clean:
++ -rm -f $(BINS)
+diff -Nuar --exclude '*~' libmelf-0.4.0.orig/Makefile.in libmelf-0.4.0/Makefile.in
+--- libmelf-0.4.0.orig/Makefile.in 2003-11-07 22:09:10.000000000 -0800
++++ libmelf-0.4.0/Makefile.in 2010-05-31 19:58:12.172822406 -0700
+@@ -6,35 +6,43 @@
+ DEFINES=@DEFINES@ -DMELF_COMP
+ INCLUDES=-I.
+ PREFIX=@PREFIX@
+-CFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} -Wall -O3
+-LFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} -Wall -O3 -o
++OPTFLAGS=-Wall -O3
++CFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} ${OPTFLAGS}
++LFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} ${OPTFLAGS} -o
++LIBDIR=lib
+ LIBS=
+ OBJS=melf.o melf_dynamic.o melf_elf.o melf_list.o melf_note.o melf_program.o melf_reloc.o \
+ melf_res.o melf_section.o melf_string.o melf_symbol.o melf_symbolTable.o
+
+-all: ${OBJS}
+- ar rc ${STATICBIN} ${OBJS} && ranlib ${STATICBIN}
+- @SHAREDEXEC@
+- cd example && make
+- cd tools && make
++all: ${STATICBIN} ${DYNAMICBIN}
++ cd example && $(MAKE)
++ cd tools && $(MAKE)
+
+ *.c.${O}:
+ ${CC} ${CFLAGS} $*.c
+
++${STATICBIN}: ${OBJS}
++ ar rc ${STATICBIN} ${OBJS} && ranlib ${STATICBIN}
++${DYNAMICBIN}: ${OBJS}
++ @SHAREDEXEC@
++
+ clean:
+ rm -f *.o ${STATICBIN} ${DYNAMICBIN} example/test example/new example/sign tools/elfres config.*
+- cd tools && make clean
++ cd tools && $(MAKE) clean
+
+-distclean:
+- make clean
++distclean: clean
+ rm -f Makefile example/Makefile stdelf.h
+- cd tools && make distclean
++ cd tools && $(MAKE) distclean
+
+ install: ${OBJS} ${STATICBIN}
+- cp libmelf.a ${PREFIX}/lib
+- cp libmelf.so ${PREFIX}/lib
++ cp ${STATICBIN} ${PREFIX}/$(LIBDIR)
++ cp ${DYNAMICBIN} ${PREFIX}/$(LIBDIR)
+ cp melf.h ${PREFIX}/include
+ cp stdelf.h ${PREFIX}/include
+
+ uninstall:
+- rm -f ${PREFIX}/lib/libmelf.a ${PREFIX}/lib/libmelf.so ${PREFIX}/include/melf.h ${PREFIX}/include/stdelf.h
++ -rm -f \
++ ${PREFIX}/$(LIBDIR)/${STATICBIN} \
++ ${PREFIX}/$(LIBDIR)/${DYNAMICBIN} \
++ ${PREFIX}/include/melf.h \
++ ${PREFIX}/include/stdelf.h
+diff -Nuar --exclude '*~' libmelf-0.4.0.orig/melf_dynamic.c libmelf-0.4.0/melf_dynamic.c
+--- libmelf-0.4.0.orig/melf_dynamic.c 2004-01-08 23:25:32.000000000 -0800
++++ libmelf-0.4.0/melf_dynamic.c 2010-05-31 19:35:59.230823053 -0700
+@@ -227,7 +227,7 @@
+ return NULL;
+
+ dynamic->content = (void *)base;
+- (unsigned char *)base += dynamic->contentLength;
++ /*(unsigned char *)*/ base += dynamic->contentLength;
+ dynamic->contentLength = newLength;
+
+ base->d_tag = DT_NULL;
+diff -Nuar --exclude '*~' libmelf-0.4.0.orig/melf_note.c libmelf-0.4.0/melf_note.c
+--- libmelf-0.4.0.orig/melf_note.c 2004-01-08 23:25:56.000000000 -0800
++++ libmelf-0.4.0/melf_note.c 2010-05-31 19:36:11.535947632 -0700
+@@ -205,7 +205,7 @@
+ return NULL;
+
+ note->content = (void *)base;
+- (unsigned char *)base += note->contentLength;
++ /*(unsigned char *)*/ base += note->contentLength;
+
+ memset(base, 0, newLength - note->contentLength);
+
+diff -Nuar --exclude '*~' libmelf-0.4.0.orig/tools/Makefile.in libmelf-0.4.0/tools/Makefile.in
+--- libmelf-0.4.0.orig/tools/Makefile.in 2003-09-17 01:03:49.000000000 -0700
++++ libmelf-0.4.0/tools/Makefile.in 2010-05-31 19:57:55.126198024 -0700
+@@ -1,11 +1,15 @@
+ cc=@CC@
+ DEFINES=@DEFINES@
++CFLAGS=${DEFINES} ${OPTFLAGS} -I..
++BINS=elfres
+
+-all:
+- ${CC} ${DEFINES} -I.. -Wall -O3 elfres.c -o elfres ../libmelf.a
++%: %.c
++ ${CC} $(CFLAGS) $^ -o $@ -L.. -lmelf
++
++all: $(BINS)
+
+ clean:
+- rm -f elfres
++ -rm -f $(BINS)
+
+ distclean:
+- rm -f elfres Makefile
++ -rm -f $(BINS) Makefile
diff --git a/dev-libs/libmelf/files/libmelf-0.4.0-r1-gcc-makefile-cleanup.patch b/dev-libs/libmelf/files/libmelf-0.4.0-r1-gcc-makefile-cleanup.patch
new file mode 100644
index 000000000000..384818f57630
--- /dev/null
+++ b/dev-libs/libmelf/files/libmelf-0.4.0-r1-gcc-makefile-cleanup.patch
@@ -0,0 +1,105 @@
+diff -Nuar --exclude '*~' libmelf-0.4.0.orig/example/Makefile.in libmelf-0.4.0/example/Makefile.in
+--- libmelf-0.4.0.orig/example/Makefile.in 2003-03-24 00:48:22.000000000 -0800
++++ libmelf-0.4.0/example/Makefile.in 2010-05-31 19:56:43.546947560 -0700
+@@ -1,7 +1,13 @@
+ cc=@CC@
+ DEFINES=@DEFINES@
++OPTFLAGS=-Wall -O3
++CFLAGS=${DEFINES} ${OPTFLAGS} -I..
++BINS = sign test new
+
+-all:
+- ${CC} ${DEFINES} -I.. -Wall -O3 sign.c -o sign ../libmelf.a
+- ${CC} ${DEFINES} -I.. -Wall -O3 test.c -o test ../libmelf.a
+- ${CC} ${DEFINES} -I.. -Wall -O3 new.c -o new ../libmelf.a
++%: %.c
++ ${CC} $(CFLAGS) $^ -o $@ -L.. -lmelf
++
++all: $(BINS)
++
++clean:
++ -rm -f $(BINS)
+diff -Nuar --exclude '*~' libmelf-0.4.0.orig/Makefile.in libmelf-0.4.0/Makefile.in
+--- libmelf-0.4.0.orig/Makefile.in 2003-11-07 22:09:10.000000000 -0800
++++ libmelf-0.4.0/Makefile.in 2010-05-31 19:58:12.172822406 -0700
+@@ -6,35 +6,43 @@
+ DEFINES=@DEFINES@ -DMELF_COMP
+ INCLUDES=-I.
+ PREFIX=@PREFIX@
+-CFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} -Wall -O3 -fPIC
+-LFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} -Wall -O3 -o
++OPTFLAGS=-Wall -O3
++CFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} ${OPTFLAGS}
++LFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} ${OPTFLAGS} -o
++LIBDIR=lib
+ LIBS=
+ OBJS=melf.o melf_dynamic.o melf_elf.o melf_list.o melf_note.o melf_program.o melf_reloc.o \
+ melf_res.o melf_section.o melf_string.o melf_symbol.o melf_symbolTable.o
+
+-all: ${OBJS}
+- ar rc ${STATICBIN} ${OBJS} && ranlib ${STATICBIN}
+- @SHAREDEXEC@
+- cd example && make
+- cd tools && make
++all: ${STATICBIN} ${DYNAMICBIN}
++ cd example && $(MAKE)
++ cd tools && $(MAKE)
+
+ *.c.${O}:
+ ${CC} ${CFLAGS} $*.c
+
++${STATICBIN}: ${OBJS}
++ ar rc ${STATICBIN} ${OBJS} && ranlib ${STATICBIN}
++${DYNAMICBIN}: ${OBJS}
++ @SHAREDEXEC@
++
+ clean:
+ rm -f *.o ${STATICBIN} ${DYNAMICBIN} example/test example/new example/sign tools/elfres config.*
+- cd tools && make clean
++ cd tools && $(MAKE) clean
+
+-distclean:
+- make clean
++distclean: clean
+ rm -f Makefile example/Makefile stdelf.h
+- cd tools && make distclean
++ cd tools && $(MAKE) distclean
+
+ install: ${OBJS} ${STATICBIN}
+- cp libmelf.a ${PREFIX}/lib
+- cp libmelf.so ${PREFIX}/lib
++ cp ${STATICBIN} ${PREFIX}/$(LIBDIR)
++ cp ${DYNAMICBIN} ${PREFIX}/$(LIBDIR)
+ cp melf.h ${PREFIX}/include
+ cp stdelf.h ${PREFIX}/include
+
+ uninstall:
+- rm -f ${PREFIX}/lib/libmelf.a ${PREFIX}/lib/libmelf.so ${PREFIX}/include/melf.h ${PREFIX}/include/stdelf.h
++ -rm -f \
++ ${PREFIX}/$(LIBDIR)/${STATICBIN} \
++ ${PREFIX}/$(LIBDIR)/${DYNAMICBIN} \
++ ${PREFIX}/include/melf.h \
++ ${PREFIX}/include/stdelf.h
+diff -Nuar --exclude '*~' libmelf-0.4.0.orig/tools/Makefile.in libmelf-0.4.0/tools/Makefile.in
+--- libmelf-0.4.0.orig/tools/Makefile.in 2003-09-17 01:03:49.000000000 -0700
++++ libmelf-0.4.0/tools/Makefile.in 2010-05-31 19:57:55.126198024 -0700
+@@ -1,11 +1,15 @@
+ cc=@CC@
+ DEFINES=@DEFINES@
++CFLAGS=${DEFINES} ${OPTFLAGS} -I..
++BINS=elfres
+
+-all:
+- ${CC} ${DEFINES} -I.. -Wall -O3 elfres.c -o elfres ../libmelf.a
++%: %.c
++ ${CC} $(CFLAGS) $^ -o $@ -L.. -lmelf
++
++all: $(BINS)
+
+ clean:
+- rm -f elfres
++ -rm -f $(BINS)
+
+ distclean:
+- rm -f elfres Makefile
++ -rm -f $(BINS) Makefile
diff --git a/dev-libs/libmelf/files/libmelf-0.4.1-unfinal-release.patch b/dev-libs/libmelf/files/libmelf-0.4.1-unfinal-release.patch
new file mode 100644
index 000000000000..359ceda352bb
--- /dev/null
+++ b/dev-libs/libmelf/files/libmelf-0.4.1-unfinal-release.patch
@@ -0,0 +1,145 @@
+diff -Nuar --exclude enum_sym --exclude configure libmelf-0.4.0.orig//ChangeLog elfsign-0.2.2/melf//ChangeLog
+--- libmelf-0.4.0.orig//ChangeLog 2004-05-03 22:15:29.000000000 -0700
++++ elfsign-0.2.2/melf//ChangeLog 2004-11-30 08:14:39.000000000 -0800
+@@ -1,3 +1,7 @@
++0.4.1
++
++ * Fixed issues with serializing SHT_DYNSYM
++
+ 0.4.0 05/04/2004
+
+ * Major enhancements to make the library more robust
+diff -Nuar --exclude enum_sym --exclude configure libmelf-0.4.0.orig//configure.in elfsign-0.2.2/melf//configure.in
+--- libmelf-0.4.0.orig//configure.in 2003-11-07 22:08:15.000000000 -0800
++++ elfsign-0.2.2/melf//configure.in 2004-06-05 10:44:17.000000000 -0700
+@@ -25,7 +25,7 @@
+ if test "x$cache_sys_os" = "xSolaris"; then
+ SHAREDEXEC="ld -dy -r -o libmelf.so \${OBJS}"
+ else
+- SHAREDEXEC="\${CC} \${FLAGS} -shared -fPIC \${OBJS} -o libmelf.so"
++ SHAREDEXEC="\${CC} \${FLAGS} -shared \${OBJS} -o libmelf.so"
+ fi
+
+ AC_C_BIGENDIAN()
+diff -Nuar --exclude enum_sym --exclude configure libmelf-0.4.0.orig//example/enum_sym.c elfsign-0.2.2/melf//example/enum_sym.c
+--- libmelf-0.4.0.orig//example/enum_sym.c 1969-12-31 16:00:00.000000000 -0800
++++ elfsign-0.2.2/melf//example/enum_sym.c 2004-11-27 18:04:36.000000000 -0800
+@@ -0,0 +1,39 @@
++#include <stdlib.h>
++#include <stdio.h>
++
++#include "melf.h"
++
++void enum_symtab(MELF *melf, ELF_SPEC_HEADER *curr);
++
++int main(int argc, char **argv)
++{
++ ELF_SPEC_HEADER *curr;
++ MELF *melf = melf_open(argv[1], MELF_ACCESS_ALL);
++
++ if (!melf)
++ return 0;
++
++ for (curr = melf_sectionGetEnum(melf);
++ curr;
++ curr = melf_sectionEnumNext(melf, curr))
++ {
++ if ((curr->spec.section.sh_type == SHT_DYNSYM) ||
++ (curr->spec.section.sh_type == SHT_SYMTAB))
++ {
++ enum_symtab(melf, curr);
++ }
++ }
++
++ return 0;
++}
++
++void enum_symtab(MELF *melf, ELF_SPEC_HEADER *curr)
++{
++ Elf32_Sym *sym;
++ unsigned long index = 0;
++
++ while ((sym = melf_symbolTableEnum(melf, curr, index++)))
++ {
++ printf("%s\n", melf_symbolGetName(melf, curr, sym));
++ }
++}
+diff -Nuar --exclude enum_sym --exclude configure libmelf-0.4.0.orig//Makefile.in elfsign-0.2.2/melf//Makefile.in
+--- libmelf-0.4.0.orig//Makefile.in 2003-11-07 22:09:10.000000000 -0800
++++ elfsign-0.2.2/melf//Makefile.in 2004-06-05 10:44:06.000000000 -0700
+@@ -6,7 +6,7 @@
+ DEFINES=@DEFINES@ -DMELF_COMP
+ INCLUDES=-I.
+ PREFIX=@PREFIX@
+-CFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} -Wall -O3
++CFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} -Wall -O3 -fPIC
+ LFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} -Wall -O3 -o
+ LIBS=
+ OBJS=melf.o melf_dynamic.o melf_elf.o melf_list.o melf_note.o melf_program.o melf_reloc.o \
+diff -Nuar --exclude enum_sym --exclude configure libmelf-0.4.0.orig//melf_dynamic.c elfsign-0.2.2/melf//melf_dynamic.c
+--- libmelf-0.4.0.orig//melf_dynamic.c 2004-01-08 23:25:32.000000000 -0800
++++ elfsign-0.2.2/melf//melf_dynamic.c 2004-12-19 13:12:45.000000000 -0800
+@@ -227,7 +227,7 @@
+ return NULL;
+
+ dynamic->content = (void *)base;
+- (unsigned char *)base += dynamic->contentLength;
++ base = (Elf32_Dyn *)((char *)base + dynamic->contentLength);
+ dynamic->contentLength = newLength;
+
+ base->d_tag = DT_NULL;
+diff -Nuar --exclude enum_sym --exclude configure libmelf-0.4.0.orig//melf_note.c elfsign-0.2.2/melf//melf_note.c
+--- libmelf-0.4.0.orig//melf_note.c 2004-01-08 23:25:56.000000000 -0800
++++ elfsign-0.2.2/melf//melf_note.c 2004-12-19 13:13:16.000000000 -0800
+@@ -204,8 +204,8 @@
+ if (!base)
+ return NULL;
+
+- note->content = (void *)base;
+- (unsigned char *)base += note->contentLength;
++ note->content = (void *)base;
++ base = (Elf32_Nhdr *)((char *)base + note->contentLength);
+
+ memset(base, 0, newLength - note->contentLength);
+
+diff -Nuar --exclude enum_sym --exclude configure libmelf-0.4.0.orig//melf_section.c elfsign-0.2.2/melf//melf_section.c
+--- libmelf-0.4.0.orig//melf_section.c 2004-05-03 21:37:29.000000000 -0700
++++ elfsign-0.2.2/melf//melf_section.c 2004-11-27 17:46:45.000000000 -0800
+@@ -485,6 +485,7 @@
+ melf_relocInitializeRelaEntryList(melf, sect);
+ break;
+ case SHT_SYMTAB:
++ case SHT_DYNSYM:
+ melf_symbolTableInitializeEntryList(melf, sect);
+ break;
+ case SHT_DYNAMIC:
+@@ -511,6 +512,7 @@
+ case SHT_REL:
+ case SHT_RELA:
+ case SHT_SYMTAB:
++ case SHT_DYNSYM:
+ case SHT_DYNAMIC:
+ case SHT_NOTE:
+ case SHT_RES:
+@@ -534,6 +536,7 @@
+ melf_relocSynchronizeRelaEntryList(melf, sect);
+ break;
+ case SHT_SYMTAB:
++ case SHT_DYNSYM:
+ melf_symbolTableSynchronizeEntryList(melf, sect);
+ break;
+ case SHT_DYNAMIC:
+diff -Nuar --exclude enum_sym --exclude configure libmelf-0.4.0.orig//stdelf.h.in elfsign-0.2.2/melf//stdelf.h.in
+--- libmelf-0.4.0.orig//stdelf.h.in 2003-06-01 11:13:56.000000000 -0700
++++ elfsign-0.2.2/melf//stdelf.h.in 2004-05-11 07:38:17.000000000 -0700
+@@ -919,8 +919,8 @@
+ #define AT_FLAGS 8 /* Flags */
+ #define AT_ENTRY 9 /* Entry point of program */
+ #define AT_NOTELF 10 /* Program is not ELF */
+-#define AT_UID 11 /* Real uid */
+-#define AT_EUID 12 /* Effective uid */
++#define E_AT_UID 11 /* Real uid */
++#define E_AT_EUID 12 /* Effective uid */
+ #define AT_GID 13 /* Real gid */
+ #define AT_EGID 14 /* Effective gid */
+ #define AT_CLKTCK 17 /* Frequency of times() */