summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-26 11:00:22 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-26 11:50:58 +0200
commit193b3bcc602334a0f33094f5773efe689996a436 (patch)
treebc23d469bc49d7bc06848fe3c5dc5f151f1c3db8 /dev-libs/libnatspec
parentsys-fs/reiserfsprogs: Bump to version 3.6.27 (diff)
downloadgentoo-193b3bcc602334a0f33094f5773efe689996a436.tar.gz
gentoo-193b3bcc602334a0f33094f5773efe689996a436.tar.bz2
gentoo-193b3bcc602334a0f33094f5773efe689996a436.zip
dev-libs/libnatspec: Bump to version 0.3.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libnatspec')
-rw-r--r--dev-libs/libnatspec/Manifest1
-rw-r--r--dev-libs/libnatspec/libnatspec-0.3.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libnatspec/Manifest b/dev-libs/libnatspec/Manifest
index 3df091b75b3d..62103661b7de 100644
--- a/dev-libs/libnatspec/Manifest
+++ b/dev-libs/libnatspec/Manifest
@@ -1 +1,2 @@
DIST libnatspec-0.2.6.tar.bz2 500525 SHA256 c3831f7373501ed7b23ffb03d9a78650dee93dbf997a61767b7dea009d4a757f SHA512 6bed3c8b2937ee27666a7deedcdebd7b24a8f495be63008fd70c467de4ab532e6448e6b682ed3be04a3a60ed64acaa0074d87231a421f6c73d6a7ee1d17bc66b WHIRLPOOL 04848603498ab27ea5dc09f1352e08632b3a182e4e2f0cdc0cb0f650709533ae13e768f973e94425a1088da3c8b090ca4e9cd047b0c1394e89742ab3a5a8d542
+DIST libnatspec-0.3.0.tar.bz2 127265 SHA256 678db5f2e25be3e79183ecc9ff6b19fb66775bcb6c3c962ba7716bc4a8ecce71 SHA512 5c04358d20be5b6ffc7038bddd4514c4b5b4e9940fb6247070b832da9d059b31fd1306cf29f54e4a1b8be1d909176bd72e6ffa98e4b750840764f9b2c250d31c WHIRLPOOL a201b94e35c5076799bb1f7d8627c62e626f296f649ca1b0b256448e78ac0a5d92609c199bcd1aef897734b69c26a2b5b666b0c9f8483e006aba1a185890d14f
diff --git a/dev-libs/libnatspec/libnatspec-0.3.0.ebuild b/dev-libs/libnatspec/libnatspec-0.3.0.ebuild
new file mode 100644
index 000000000000..beeaea380a0b
--- /dev/null
+++ b/dev-libs/libnatspec/libnatspec-0.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="library to smooth charset/localization issues"
+HOMEPAGE="http://natspec.sourceforge.net/"
+SRC_URI="mirror://sourceforge/natspec/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/popt
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/tcl:0= )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.6-iconv.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # regenerate to fix imcompatible readlink usage
+ rm -f "${S}"/ltmain.sh "${S}"/libtool || die
+ eautoreconf
+}
+
+src_configure() {
+ use doc || export ac_cv_prog_DOX=no
+ # braindead configure script does not disable python on --without-python
+ econf $(use python && use_with python)
+}