summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-14 10:52:58 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-14 10:53:13 +0200
commit37cc858514b20cbae854b7d380870774380bc277 (patch)
tree0635385103fb77194283b892151698a23a642dbc /dev-libs/libnl
parentdev-vcs/subversion: Bump to version 1.13.0_rc1 (diff)
downloadgentoo-37cc858514b20cbae854b7d380870774380bc277.tar.gz
gentoo-37cc858514b20cbae854b7d380870774380bc277.tar.bz2
gentoo-37cc858514b20cbae854b7d380870774380bc277.zip
dev-libs/libnl: Update live ebuild
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-libs/libnl')
-rw-r--r--dev-libs/libnl/libnl-99999999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/libnl/libnl-99999999.ebuild b/dev-libs/libnl/libnl-99999999.ebuild
index 43eb90b83be5..bb976be45138 100644
--- a/dev-libs/libnl/libnl-99999999.ebuild
+++ b/dev-libs/libnl/libnl-99999999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
DISTUTILS_OPTIONAL=1
-inherit autotools distutils-r1 eutils git-r3 libtool multilib multilib-minimal
+inherit autotools distutils-r1 git-r3 libtool multilib multilib-minimal
DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
HOMEPAGE="http://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
@@ -84,7 +84,7 @@ multilib_src_compile() {
}
multilib_src_install() {
- emake DESTDIR="${D}" install
+ default
if multilib_is_native_abi && use python; then
# Unset DOCS= since distutils-r1.eclass interferes
@@ -96,5 +96,5 @@ multilib_src_install() {
multilib_src_install_all() {
einstalldocs
- prune_libtool_files --modules
+ find "${D}" -name '*.la' -delete || die
}