summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-10-02 22:48:49 +0200
committerJeroen Roovers <jer@gentoo.org>2017-10-02 22:49:13 +0200
commit3b06191263626e8040ec9d93dd8c63454b42f2c7 (patch)
tree5822fdeed2ddf52a794472196791f26e0859ac74 /dev-libs/libnl
parentsys-devel/gcc-config: Remove ugly workaround for 12 years gone bug, bug 554334 (diff)
downloadgentoo-3b06191263626e8040ec9d93dd8c63454b42f2c7.tar.gz
gentoo-3b06191263626e8040ec9d93dd8c63454b42f2c7.tar.bz2
gentoo-3b06191263626e8040ec9d93dd8c63454b42f2c7.zip
dev-libs/libnl: Version bump.
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libnl')
-rw-r--r--dev-libs/libnl/Manifest2
-rw-r--r--dev-libs/libnl/libnl-3.4.0_rc1.ebuild107
2 files changed, 109 insertions, 0 deletions
diff --git a/dev-libs/libnl/Manifest b/dev-libs/libnl/Manifest
index f4499e0dd6fe..82048ff5acee 100644
--- a/dev-libs/libnl/Manifest
+++ b/dev-libs/libnl/Manifest
@@ -3,3 +3,5 @@ DIST libnl-3.2.28-in6.patch.xz 6368 SHA256 0cbb8dc4e3cdc90a4a0608a26af1971d7c1c3
DIST libnl-3.2.28.tar.gz 941954 SHA256 cd608992c656e8f6e3ab6c1391b162a5a51c49336b9219f7f390e61fc5437c41 SHA512 b5f145ecafb2625ed1c42594afd6063f112a601077de5c35884b3c3bc8c562b29b52a006ccebd795c127fe69692a82def425c8605afed7e6d441582943e803d9 WHIRLPOOL ff49346ddc31105a300ebffc0e4d4956ac85ade5e92e884c62e696d7d4234d40e63cf4839e6b6fd2d98d2122662d36d3f41666391686a83c8bf966e53e22ed25
DIST libnl-3.2.29.tar.gz 963681 SHA256 0beb593dc6abfffa18a5c787b27884979c1b7e7f1fd468c801e3cc938a685922 SHA512 45e22b02368c479e01db7160345a0d3c73abf345e7b49bf350811243a17f307f5c6c3df639ec1e0c456707578aca8d69aad8afa697ac21449f521a3e39712670 WHIRLPOOL 1273dcaee79ecfdca947110c5e7ff70947703b1b0fda43fdb7c74edd78c6938f675e9a586aaff8feefce56a1f3137cbc50d3626ac336e6afa2ca8cbd8627e6eb
DIST libnl-3.3.0.tar.gz 933390 SHA256 705468b5ae4cd1eb099d2d1c476d6a3abe519bc2810becf12fb1e32de1e074e4 SHA512 3fc5d95b875605ab6378d2d454020c1276a6772205fa11bbd22eba9fd9ef1deb8c75347e5d4602f0ab7bf13bd66b418f5ef73ed05f18134f08638ce06eef622c WHIRLPOOL a6f7c066c9d05af807ed17babe1f39107d24b4b5ef44ca94e487543a39b0a2f1298fbf6448356fa3701c033fbff0df392945666c125f16246398d47a8c828f5b
+DIST libnl-3.4.0-rc1.tar.gz 945094 SHA256 31eae336fe4383ec52eea9dd2db51f33ac83cd1c349e4a31ed80c777eed7d0fe SHA512 f0a3c6d368b2b60b198a7e96d67a99daefb3bad194961c5472bd6401e6c274058b7a7173015b73d90df41db43c7ffdfd99252f6378dc5912a33e4e70212e0c75 WHIRLPOOL e156c2400ebe5827cbbfb9ae84bf71fa569ab1c7e8e44c7f00492cffd01e629ee90afa88bcc374e04711187ec083932a5c7c2fef28b3ac25d76e69f1d75a36b4
+DIST libnl-3.4.0_rc1.tar.xz 1124 SHA256 3857952e47656e7f50ecf55ca40b9e67b9a4864b4bcb1a126ddd380956f5dc9f SHA512 6175e3234691d0ff875e6cde79ec93ff7dec1deb66300e8fffe54a5a7d816c5a73d0a4ad371f962792181622d20c59fc3ff7c086062d4f20db18a7b99b050858 WHIRLPOOL b88b5a5f81201c689c181f88f0b7d59b3fad717ee875cf09282dc943350a78f83aaedac50cdf94b40a10b4ce258b63fa9906b75a0eed1b83dd27c1d927ef0a92
diff --git a/dev-libs/libnl/libnl-3.4.0_rc1.ebuild b/dev-libs/libnl/libnl-3.4.0_rc1.ebuild
new file mode 100644
index 000000000000..1a3dd0f0879d
--- /dev/null
+++ b/dev-libs/libnl/libnl-3.4.0_rc1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+DISTUTILS_OPTIONAL=1
+inherit distutils-r1 eutils libtool multilib multilib-minimal
+
+LIBNL_P=${P/_/-}
+LIBNL_DIR=${PV/_/}
+LIBNL_DIR=${LIBNL_DIR//./_}
+
+DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
+HOMEPAGE="http://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
+SRC_URI="
+ https://github.com/thom311/${PN}/releases/download/${PN}${LIBNL_DIR}/${P/_rc/-rc}.tar.gz
+ https://dev.gentoo.org/~jer/${P}.tar.xz
+"
+LICENSE="LGPL-2.1 utils? ( GPL-2 )"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs python utils"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r5
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ python? ( dev-lang/swig )
+ sys-devel/bison
+ sys-devel/flex
+"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+DOCS=(
+ ChangeLog
+)
+
+S=${WORKDIR}/${LIBNL_P}
+
+MULTILIB_WRAPPED_HEADERS=(
+ # we do not install CLI stuff for non-native
+ /usr/include/libnl3/netlink/cli/addr.h
+ /usr/include/libnl3/netlink/cli/class.h
+ /usr/include/libnl3/netlink/cli/cls.h
+ /usr/include/libnl3/netlink/cli/ct.h
+ /usr/include/libnl3/netlink/cli/exp.h
+ /usr/include/libnl3/netlink/cli/link.h
+ /usr/include/libnl3/netlink/cli/neigh.h
+ /usr/include/libnl3/netlink/cli/qdisc.h
+ /usr/include/libnl3/netlink/cli/route.h
+ /usr/include/libnl3/netlink/cli/rule.h
+ /usr/include/libnl3/netlink/cli/tc.h
+ /usr/include/libnl3/netlink/cli/utils.h
+)
+
+src_prepare() {
+ default
+
+ elibtoolize
+
+ if use python; then
+ cd "${S}"/python || die
+ distutils-r1_src_prepare
+ fi
+
+ # out-of-source build broken
+ # https://github.com/thom311/libnl/pull/58
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ --disable-silent-rules \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_enable utils cli)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use python; then
+ cd python || die
+ distutils-r1_src_compile
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use python; then
+ # Unset DOCS= since distutils-r1.eclass interferes
+ local DOCS=()
+ cd python || die
+ distutils-r1_src_install
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}