summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 06:17:07 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:54:21 +0100
commitaf8e074ce565eb254c26a623208600a3c58a2161 (patch)
tree4513db6bb7e9363e129d3b76fdb57afc761304b9 /dev-libs/libnl
parentdev-libs/liblist: use BDEPEND, autotools-- (diff)
downloadgentoo-af8e074ce565eb254c26a623208600a3c58a2161.tar.gz
gentoo-af8e074ce565eb254c26a623208600a3c58a2161.tar.bz2
gentoo-af8e074ce565eb254c26a623208600a3c58a2161.zip
dev-libs/libnl: use BDEPEND, multilib--, missing || dies
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libnl')
-rw-r--r--dev-libs/libnl/libnl-1.1.4-r1.ebuild14
-rw-r--r--dev-libs/libnl/libnl-1.1.9999.ebuild19
2 files changed, 20 insertions, 13 deletions
diff --git a/dev-libs/libnl/libnl-1.1.4-r1.ebuild b/dev-libs/libnl/libnl-1.1.4-r1.ebuild
index 40141bb55b71..e353d9ccc9be 100644
--- a/dev-libs/libnl/libnl-1.1.4-r1.ebuild
+++ b/dev-libs/libnl/libnl-1.1.4-r1.ebuild
@@ -2,11 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit multilib toolchain-funcs
+
+inherit toolchain-funcs
DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
HOMEPAGE="https://www.infradead.org/~tgr/libnl/"
SRC_URI="http://www.infradead.org/~tgr/libnl/files/${P}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="1.1"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
@@ -14,6 +16,7 @@ IUSE="doc static-libs"
DEPEND="doc? ( app-doc/doxygen )"
DOCS=( ChangeLog )
+
PATCHES=(
"${FILESDIR}"/${PN}-1.1-vlan-header.patch
"${FILESDIR}"/${PN}-1.1-flags.patch
@@ -34,14 +37,14 @@ src_prepare() {
sed -i lib/Makefile -e '/OUT_AR/d' || die
fi
- rm -f lib/libnl.a
+ rm -f lib/libnl.a || die
}
src_compile() {
- emake AR=$(tc-getAR)
+ emake AR="$(tc-getAR)"
if use doc ; then
- cd "${S}/doc"
+ cd "${S}/doc" || die
emake gendoc
fi
}
@@ -50,7 +53,8 @@ src_install() {
default
if use doc ; then
- cd "${S}/doc"
+ cd "${S}/doc" || die
+
docinto html
dodoc -r html/*
fi
diff --git a/dev-libs/libnl/libnl-1.1.9999.ebuild b/dev-libs/libnl/libnl-1.1.9999.ebuild
index 30fa4a923c0f..14a4835802c4 100644
--- a/dev-libs/libnl/libnl-1.1.9999.ebuild
+++ b/dev-libs/libnl/libnl-1.1.9999.ebuild
@@ -2,18 +2,21 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 multilib toolchain-funcs
+
+inherit git-r3 toolchain-funcs
DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
HOMEPAGE="https://www.infradead.org/~tgr/libnl/"
EGIT_REPO_URI="https://github.com/tgraf/libnl-1.1-stable"
+
LICENSE="LGPL-2.1"
SLOT="1.1"
-KEYWORDS=""
IUSE="doc static-libs"
-DEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="doc? ( app-doc/doxygen )"
+
DOCS=( ChangeLog )
+
PATCHES=(
"${FILESDIR}"/${PN}-1.1-vlan-header.patch
"${FILESDIR}"/${PN}-1.1-flags.patch
@@ -30,18 +33,18 @@ src_prepare() {
-e 's|-g ||g' \
Makefile.opts.in || die
- if ! use static-libs; then
+ if ! use static-libs ; then
sed -i lib/Makefile -e '/OUT_AR/d' || die
fi
- rm -f lib/libnl.a
+ rm -f lib/libnl.a || die
}
src_compile() {
- emake AR=$(tc-getAR)
+ emake AR="$(tc-getAR)"
if use doc ; then
- cd "${S}/doc"
+ cd "${S}/doc" || die
emake gendoc
fi
}
@@ -50,7 +53,7 @@ src_install() {
default
if use doc ; then
- cd "${S}/doc"
+ cd "${S}/doc" || die
docinto html
dodoc -r html/*
fi