summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-06-20 19:32:59 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-06-20 19:33:23 +0300
commitc88208d85b3a526766fd02657fcc13373ce51d47 (patch)
treecc089b2062d28b860ef9743d334f5c7979a1ea97 /dev-libs/libp11/libp11-0.4.7.ebuild
parentapp-crypt/p11-kit: version bump (diff)
downloadgentoo-c88208d85b3a526766fd02657fcc13373ce51d47.tar.gz
gentoo-c88208d85b3a526766fd02657fcc13373ce51d47.tar.bz2
gentoo-c88208d85b3a526766fd02657fcc13373ce51d47.zip
dev-libs/libp11: version bump
Closes: https://bugs.gentoo.org/show_bug.cgi?id=658462 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libp11/libp11-0.4.7.ebuild')
-rw-r--r--dev-libs/libp11/libp11-0.4.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libp11/libp11-0.4.7.ebuild b/dev-libs/libp11/libp11-0.4.7.ebuild
new file mode 100644
index 000000000000..ef1ce17e2ae0
--- /dev/null
+++ b/dev-libs/libp11/libp11-0.4.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit ltprune
+
+DESCRIPTION="Abstraction layer to simplify PKCS#11 API"
+HOMEPAGE="https://github.com/opensc/libp11/wiki"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libressl bindist doc static-libs"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable doc api-doc)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}