summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-06-04 14:58:59 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-06-07 12:38:49 +0200
commit34b8482e5b18c1242dfd3d5407c1da6a0a3d86af (patch)
tree60ada94a214901b871bb71cdae3b12f7705429ae /dev-libs/libpcre
parentmedia-libs/gegl: ia64 stable, bug #591618 (diff)
downloadgentoo-34b8482e5b18c1242dfd3d5407c1da6a0a3d86af.tar.gz
gentoo-34b8482e5b18c1242dfd3d5407c1da6a0a3d86af.tar.bz2
gentoo-34b8482e5b18c1242dfd3d5407c1da6a0a3d86af.zip
dev-libs/libpcre: Security cleanup (bug #609592)
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4848
Diffstat (limited to 'dev-libs/libpcre')
-rw-r--r--dev-libs/libpcre/Manifest1
-rw-r--r--dev-libs/libpcre/libpcre-8.39.ebuild94
-rw-r--r--dev-libs/libpcre/libpcre-8.40.ebuild94
3 files changed, 0 insertions, 189 deletions
diff --git a/dev-libs/libpcre/Manifest b/dev-libs/libpcre/Manifest
index ec5ea1113752..dacf77de3e9e 100644
--- a/dev-libs/libpcre/Manifest
+++ b/dev-libs/libpcre/Manifest
@@ -1,2 +1 @@
-DIST pcre-8.39.tar.bz2 1560758 SHA256 b858099f82483031ee02092711689e7245586ada49e534a06e678b8ea9549e8b SHA512 8b0f14ae5947c4b2d74876a795b04e532fd71c2479a64dbe0ed817e7c7894ea3cae533413de8c17322d305cb7f4e275d72b43e4e828eaca77dc4bcaf04529cf6 WHIRLPOOL 00e8e7fb3dc60cbbd2ee185e269696058b568a0f269749386bad44cb474f723c9ed3dfd2af91ddce0b5047aab459864f07e05940af17d3d51d2f1b068415b1ed
DIST pcre-8.40.tar.bz2 1560119 SHA256 00e27a29ead4267e3de8111fcaa59b132d0533cdfdbdddf4b0604279acbcf4f4 SHA512 b4c27eafbdf33bd7a1384655b1936f4be3bc6745c072347eb26e988896c52664bd85ac42444da1be78b6e20f45b6c7e5921f5f20f5b0741b5bd3d9844e5bd4e2 WHIRLPOOL 6711688972b3db4b98902d548b84e8b03b61c3a12d24a4e42fc49ddc5e2b4be51f98f91873166e550866e88b6cd55092ea27704a3b7e71d58a2af21148ad3340
diff --git a/dev-libs/libpcre/libpcre-8.39.ebuild b/dev-libs/libpcre/libpcre-8.39.ebuild
deleted file mode 100644
index 52b4b043c956..000000000000
--- a/dev-libs/libpcre/libpcre-8.39.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils multilib libtool flag-o-matic toolchain-funcs multilib-minimal
-
-DESCRIPTION="Perl-compatible regular expression library"
-HOMEPAGE="http://www.pcre.org/"
-MY_P="pcre-${PV/_rc/-RC}"
-if [[ ${PV} != *_rc* ]] ; then
- # Only the final releases are available here.
- SRC_URI="mirror://sourceforge/pcre/${MY_P}.tar.bz2
- ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
-else
- SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
-fi
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 +cxx +jit libedit pcre16 pcre32 +readline +recursion-limit static-libs unicode zlib"
-REQUIRED_USE="readline? ( !libedit )
- libedit? ( !readline )"
-
-RDEPEND="bzip2? ( app-arch/bzip2 )
- zlib? ( sys-libs/zlib )
- libedit? ( dev-libs/libedit )
- readline? ( sys-libs/readline:0= )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-RDEPEND="${RDEPEND}
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20131008-r2
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-
-S=${WORKDIR}/${MY_P}
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/pcre-config
-)
-
-#PATCHES=(
-#)
-
-src_prepare() {
- #epatch "${PATCHES[@]}"
- sed -i -e "s:-lpcre ::" libpcrecpp.pc.in || die
- elibtoolize
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- --with-match-limit-recursion=$(usex recursion-limit 8192 MATCH_LIMIT) \
- $(multilib_native_use_enable bzip2 pcregrep-libbz2) \
- $(use_enable cxx cpp) \
- $(use_enable jit) $(use_enable jit pcregrep-jit) \
- $(use_enable pcre16) \
- $(use_enable pcre32) \
- $(multilib_native_use_enable libedit pcretest-libedit) \
- $(multilib_native_use_enable readline pcretest-libreadline) \
- $(use_enable static-libs static) \
- $(use_enable unicode utf) $(use_enable unicode unicode-properties) \
- $(multilib_native_use_enable zlib pcregrep-libz) \
- --enable-pcre8 \
- --enable-shared \
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
-}
-
-multilib_src_compile() {
- emake V=1 $(multilib_is_native_abi || echo "bin_PROGRAMS=")
-}
-
-multilib_src_install() {
- emake \
- DESTDIR="${D}" \
- $(multilib_is_native_abi || echo "bin_PROGRAMS= dist_html_DATA=") \
- install
- gen_usr_ldscript -a pcre
-}
-
-multilib_src_install_all() {
- prune_libtool_files
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/libpcre.so.0
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/libpcre.so.0
-}
diff --git a/dev-libs/libpcre/libpcre-8.40.ebuild b/dev-libs/libpcre/libpcre-8.40.ebuild
deleted file mode 100644
index 6ab236db96a9..000000000000
--- a/dev-libs/libpcre/libpcre-8.40.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils multilib libtool flag-o-matic toolchain-funcs multilib-minimal
-
-DESCRIPTION="Perl-compatible regular expression library"
-HOMEPAGE="http://www.pcre.org/"
-MY_P="pcre-${PV/_rc/-RC}"
-if [[ ${PV} != *_rc* ]] ; then
- # Only the final releases are available here.
- SRC_URI="mirror://sourceforge/pcre/${MY_P}.tar.bz2
- ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
-else
- SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
-fi
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 +cxx +jit libedit pcre16 pcre32 +readline +recursion-limit static-libs unicode zlib"
-REQUIRED_USE="readline? ( !libedit )
- libedit? ( !readline )"
-
-RDEPEND="bzip2? ( app-arch/bzip2 )
- zlib? ( sys-libs/zlib )
- libedit? ( dev-libs/libedit )
- readline? ( sys-libs/readline:0= )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-RDEPEND="${RDEPEND}
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20131008-r2
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-
-S=${WORKDIR}/${MY_P}
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/pcre-config
-)
-
-#PATCHES=(
-#)
-
-src_prepare() {
- #epatch "${PATCHES[@]}"
- sed -i -e "s:-lpcre ::" libpcrecpp.pc.in || die
- elibtoolize
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- --with-match-limit-recursion=$(usex recursion-limit 8192 MATCH_LIMIT) \
- $(multilib_native_use_enable bzip2 pcregrep-libbz2) \
- $(use_enable cxx cpp) \
- $(use_enable jit) $(use_enable jit pcregrep-jit) \
- $(use_enable pcre16) \
- $(use_enable pcre32) \
- $(multilib_native_use_enable libedit pcretest-libedit) \
- $(multilib_native_use_enable readline pcretest-libreadline) \
- $(use_enable static-libs static) \
- $(use_enable unicode utf) $(use_enable unicode unicode-properties) \
- $(multilib_native_use_enable zlib pcregrep-libz) \
- --enable-pcre8 \
- --enable-shared \
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
-}
-
-multilib_src_compile() {
- emake V=1 $(multilib_is_native_abi || echo "bin_PROGRAMS=")
-}
-
-multilib_src_install() {
- emake \
- DESTDIR="${D}" \
- $(multilib_is_native_abi || echo "bin_PROGRAMS= dist_html_DATA=") \
- install
- gen_usr_ldscript -a pcre
-}
-
-multilib_src_install_all() {
- prune_libtool_files
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/libpcre.so.0
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/libpcre.so.0
-}