summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-08 09:44:45 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-11 11:21:51 +0100
commite9dd39803ff5de5e28185f3adf841aa8d552b45d (patch)
tree82c984c73e83cf58ecaa9de01c385744f0126b08 /dev-libs/libpeas/libpeas-1.14.0-r1.ebuild
parentpython-utils-r1.eclass: Reuse PYTHON_CONFIG in python_wrapper_setup() (diff)
downloadgentoo-e9dd39803ff5de5e28185f3adf841aa8d552b45d.tar.gz
gentoo-e9dd39803ff5de5e28185f3adf841aa8d552b45d.tar.bz2
gentoo-e9dd39803ff5de5e28185f3adf841aa8d552b45d.zip
dev-libs/libpeas: Obtain correct python-config path
Use new python_get_PYTHON_CONFIG API to obtain the correct path to python-config executable. This forward-fixes compatibility with ABIFLAGS-enabled Python 3.* versions, and improves readability.
Diffstat (limited to 'dev-libs/libpeas/libpeas-1.14.0-r1.ebuild')
-rw-r--r--dev-libs/libpeas/libpeas-1.14.0-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-libs/libpeas/libpeas-1.14.0-r1.ebuild b/dev-libs/libpeas/libpeas-1.14.0-r1.ebuild
index 3a1d0adbf094..35d29807398e 100644
--- a/dev-libs/libpeas/libpeas-1.14.0-r1.ebuild
+++ b/dev-libs/libpeas/libpeas-1.14.0-r1.ebuild
@@ -77,7 +77,7 @@ src_configure() {
"--enable-python${v}"
# it is just 'PYTHON' for py3 in the build system
"PYTHON${v#3}=${PYTHON}"
- "PYTHON${v}_CONFIG=${PYTHON}-config"
+ "PYTHON${v}_CONFIG=$(python_get_PYTHON_CONFIG)"
)
}
use python && python_foreach_impl python_configure