summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-26 23:32:21 +0000
committerSam James <sam@gentoo.org>2021-02-27 01:00:03 +0000
commit7a151047316051b18f580c0c9e92712789812967 (patch)
treee7ff8ecc346044de0f08399c9ef8291b90ebd4ac /dev-libs/libpfm
parentdev-libs/maloc: port to EAPI 7 (diff)
downloadgentoo-7a151047316051b18f580c0c9e92712789812967.tar.gz
gentoo-7a151047316051b18f580c0c9e92712789812967.tar.bz2
gentoo-7a151047316051b18f580c0c9e92712789812967.zip
dev-libs/libpfm: bump to 4.11.0
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libpfm')
-rw-r--r--dev-libs/libpfm/Manifest1
-rw-r--r--dev-libs/libpfm/libpfm-4.11.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libpfm/Manifest b/dev-libs/libpfm/Manifest
index cb38241422ae..8c43bf885944 100644
--- a/dev-libs/libpfm/Manifest
+++ b/dev-libs/libpfm/Manifest
@@ -1 +1,2 @@
DIST libpfm-4.10.1.tar.gz 1005988 BLAKE2B 7bdc64540cdf0404bfab0a631e506f37a79ca090d68c798fe4943f627ebc3e15e01f6c4530d4eec2c82a6f759845af518cbf34b3ad19ecc5fa48a874611aaa16 SHA512 33d99824216b4d83784e0db9f1aae3b39f84c2ba42dee64dde0b3c43cc5ee3a18c206d9044e75bf10867768add7cb9967c6318f7aa196f178f334271fa05e1aa
+DIST libpfm-4.11.0.tar.gz 1043686 BLAKE2B 99b4f1a5156316139603cf50cf42c13c548a0b196435bfc92bc26ebd3f8d7ec9584255978d4f3fbff45cddc937269961e9d2b65d065632ae635e9ca45c179a54 SHA512 633035b8a7b35973437572095cdc80d422b2a1a61e74e14f106db95fa8e44e4518e591699cc457f828b8f2fb63f60eef6d0c7535c6b4c9a6c3a70d4550b3c3c7
diff --git a/dev-libs/libpfm/libpfm-4.11.0.ebuild b/dev-libs/libpfm/libpfm-4.11.0.ebuild
new file mode 100644
index 000000000000..594f18ab5f6a
--- /dev/null
+++ b/dev-libs/libpfm/libpfm-4.11.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Hardware-based performance monitoring interface for Linux"
+HOMEPAGE="http://perfmon2.sourceforge.net"
+SRC_URI="mirror://sourceforge/perfmon2/${PN}4/${P}.tar.gz"
+
+LICENSE="GPL-2 MIT"
+SLOT="0/4"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+
+ sed -e "s:SLDFLAGS=:SLDFLAGS=\$(LDFLAGS) :g" \
+ -i lib/Makefile || die
+ sed -e "s:LIBDIR=\$(PREFIX)/lib:LIBDIR=\$(PREFIX)/$(get_libdir):g" \
+ -i config.mk || die
+}
+
+src_compile() {
+ # 'DBG=' unsets '-Werror' and other optional flags, bug #664294
+ emake AR=$(tc-getAR) CC=$(tc-getCC) DBG=
+}
+
+src_install() {
+ emake DESTDIR="${D}" LDCONFIG=true PREFIX="${EPREFIX}/usr" install
+ dodoc README
+
+ find "${ED}" -name '*.a' -delete || die
+
+ # Note: dev-libs/papi uses .la files to detect this package, so
+ # don't remove them.
+}