summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-01 01:34:01 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-01 01:35:43 +0100
commit92c9b5dcbd2ae118bc9deb016738b3263936de01 (patch)
treefd89fcd36c61246dc411119ab0813d47288d30ec /dev-libs/libprelude/libprelude-4.1.0.ebuild
parentdev-libs/libpreludedb: Remove old (py3.6) (diff)
downloadgentoo-92c9b5dcbd2ae118bc9deb016738b3263936de01.tar.gz
gentoo-92c9b5dcbd2ae118bc9deb016738b3263936de01.tar.bz2
gentoo-92c9b5dcbd2ae118bc9deb016738b3263936de01.zip
dev-libs/libprelude: Remove old (py3.6)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libprelude/libprelude-4.1.0.ebuild')
-rw-r--r--dev-libs/libprelude/libprelude-4.1.0.ebuild89
1 files changed, 0 insertions, 89 deletions
diff --git a/dev-libs/libprelude/libprelude-4.1.0.ebuild b/dev-libs/libprelude/libprelude-4.1.0.ebuild
deleted file mode 100644
index 89be5ea06931..000000000000
--- a/dev-libs/libprelude/libprelude-4.1.0.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-DISTUTILS_OPTIONAL=1
-
-inherit autotools distutils-r1 ruby-single
-
-DESCRIPTION="Prelude-SIEM Framework Library"
-HOMEPAGE="https://www.prelude-siem.org"
-SRC_URI="https://www.prelude-siem.org/pkg/src/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="lua perl python ruby"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="net-libs/gnutls:=
- lua? ( dev-lang/lua:0= )
- perl? ( dev-lang/perl:= virtual/perl-ExtUtils-MakeMaker )
- python? ( ${PYTHON_DEPS} )
- ruby? ( ${RUBY_DEPS} )"
-
-DEPEND="${RDEPEND}
- >=dev-lang/swig-3.0.11
- dev-util/gtk-doc-am
- sys-devel/flex
- virtual/pkgconfig
- virtual/yacc"
-
-PATCHES=(
- "${FILESDIR}/${PN}-4.0.0-fix-python-bindings.patch"
-)
-
-src_prepare() {
- default
-
- # Avoid null runpaths in Perl bindings.
- sed -e 's/ LD_RUN_PATH=""//' -i "${S}/bindings/Makefile.am" || die "sed failed"
-
- eautoreconf
-
- if use python; then
- cd bindings/python || die
- distutils-r1_src_prepare
- fi
-}
-
-src_configure() {
- local myconf=(
- --enable-easy-bindings
- --with-swig
- --without-python2
- $(use_with lua)
- $(use_with perl)
- $(usex perl '--with-perl-installdirs=vendor' '')
- $(use_with ruby)
- )
-
- if use python; then
- python_setup
- myconf+=( --with-python3="${EPYTHON}" )
- else
- myconf+=( --without-python3 )
- fi
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- default
- if use python; then
- cd bindings/python || die
- distutils-r1_src_compile
- fi
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
- if use python; then
- cd bindings/python || die
- distutils-r1_src_install
- fi
-}