summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Andrejak <thomas.andrejak@gmail.com>2017-08-28 00:52:01 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-08 10:19:05 +0200
commitc355e564ed8b6efec432a566c30d04cdeb0221d7 (patch)
tree07ca0194903ca13fd72ac87d953cafd74b9dbfe1 /dev-libs/libpreludedb/files
parentdev-libs/libprelude: whitespace/style fixes (diff)
downloadgentoo-c355e564ed8b6efec432a566c30d04cdeb0221d7.tar.gz
gentoo-c355e564ed8b6efec432a566c30d04cdeb0221d7.tar.bz2
gentoo-c355e564ed8b6efec432a566c30d04cdeb0221d7.zip
dev-libs/libpreludedb: Bump version 4.0.0
Diffstat (limited to 'dev-libs/libpreludedb/files')
-rw-r--r--dev-libs/libpreludedb/files/libpreludedb-4.0.0-fix-python-bindings.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libpreludedb/files/libpreludedb-4.0.0-fix-python-bindings.patch b/dev-libs/libpreludedb/files/libpreludedb-4.0.0-fix-python-bindings.patch
new file mode 100644
index 000000000000..7fb93c269ef2
--- /dev/null
+++ b/dev-libs/libpreludedb/files/libpreludedb-4.0.0-fix-python-bindings.patch
@@ -0,0 +1,39 @@
+--- a/bindings/python/Makefile.am 2017-07-18 12:27:27.278000000 +0200
++++ b/bindings/python/Makefile.am 2017-09-07 23:41:21.279920258 +0200
+@@ -6,36 +6,6 @@
+ all-am: python-build
+
+ python-build: _preludedb.cxx
+-if HAVE_PYTHON2
+- CC="$(CXX)" $(PYTHON2) setup.py build
+-endif
+-if HAVE_PYTHON3
+- CC="$(CXX)" $(PYTHON3) setup.py build
+-endif
+-install-exec-hook:
+-if HAVE_PYTHON2
+- $(PYTHON2) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
+-endif
+-if HAVE_PYTHON3
+- $(PYTHON3) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
+-endif
+-
+-uninstall-hook:
+-if HAVE_PYTHON2
+- $(PYTHON2) setup.py uninstall `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
+-endif
+-if HAVE_PYTHON3
+- $(PYTHON3) setup.py uninstall `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
+-endif
+-
+-clean-local:
+-if HAVE_PYTHON2
+- $(PYTHON2) setup.py clean -a
+-endif
+-if HAVE_PYTHON3
+- $(PYTHON3) setup.py clean -a
+-endif
+-
+
+ _preludedb.cxx preludedb.py: $(top_srcdir)/bindings/c++/include/*.hxx $(top_srcdir)/bindings/libpreludedbcpp.i libpreludedbcpp-python.i
+ if HAVE_SWIG