summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-26 14:00:32 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-26 15:31:02 +0200
commit359770761e4928f36eff9ce5cafac22da6ecef52 (patch)
tree36ab3c87a079bd0432d11ed0c03cfa25fe1d781f /dev-libs/librelp
parentdev-libs/librelp: drop old (diff)
downloadgentoo-359770761e4928f36eff9ce5cafac22da6ecef52.tar.gz
gentoo-359770761e4928f36eff9ce5cafac22da6ecef52.tar.bz2
gentoo-359770761e4928f36eff9ce5cafac22da6ecef52.zip
dev-libs/librelp: bump to v1.7.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/librelp')
-rw-r--r--dev-libs/librelp/Manifest1
-rw-r--r--dev-libs/librelp/librelp-1.7.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-libs/librelp/Manifest b/dev-libs/librelp/Manifest
index 0b8b3dd509c1..5b2f59a2ed84 100644
--- a/dev-libs/librelp/Manifest
+++ b/dev-libs/librelp/Manifest
@@ -1 +1,2 @@
DIST librelp-1.6.0.tar.gz 522827 BLAKE2B 04e608a3afe4e6e0109cc9bf753de34e9486595e33bc57387b9428bcf50f8d56177e8f849870611778636be5a58714e4640048758c83a041a354f70442d55cf0 SHA512 1bf96b700fa5ab648ed671b341ae7101fc1db4107f178abd507647afe4f12d59a94c821cc0e06998ac7b344ed41a5e3821843c722c82bf5284c6556995391228
+DIST librelp-1.7.0.tar.gz 532967 BLAKE2B 19e3eaa05aa7a53b4701eaf96b3be6d8467c7f5c0de0bc1ba81fcb6d6ed6529146140a32b05fcdb47330be2b573a9d84779ea519dd9cacf50d3b7710d523b808 SHA512 e9d71f27d5c50b043254a3f1b0643e7172e5678b6a5a7dddb9d4a9e3afa3ed0adf818a4e868960c1607da5f63430f163f9e76c882ed5460149cb1cceff42b4bd
diff --git a/dev-libs/librelp/librelp-1.7.0.ebuild b/dev-libs/librelp/librelp-1.7.0.ebuild
new file mode 100644
index 000000000000..edacd29ee8ed
--- /dev/null
+++ b/dev-libs/librelp/librelp-1.7.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="An easy to use library for the RELP protocol"
+HOMEPAGE="https://www.rsyslog.com/librelp/"
+SRC_URI="https://download.rsyslog.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ doc? ( FDL-1.3 )"
+
+# subslot = soname version
+SLOT="0/0.5.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+IUSE="debug doc +ssl +gnutls libressl openssl static-libs test"
+REQUIRED_USE="ssl? ( ^^ ( gnutls openssl ) )"
+
+RDEPEND="
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-3.3.17.1:0= )
+ openssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ virtual/pkgconfig"
+
+RESTRICT="!test? ( test )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e 's/ -g"/"/g' \
+ configure.ac || die "sed failed"
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-valgrind
+ $(use_enable debug)
+ $(use_enable gnutls tls)
+ $(use_enable openssl tls-openssl)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ local DOCS=( ChangeLog )
+ use doc && local HTML_DOCS=( doc/relp.html )
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}