summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/librep
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/librep')
-rw-r--r--dev-libs/librep/Manifest2
-rw-r--r--dev-libs/librep/files/50librep-gentoo.el6
-rw-r--r--dev-libs/librep/files/librep-0.92.0-disable-elisp.patch19
-rw-r--r--dev-libs/librep/librep-0.92.2.1.ebuild67
-rw-r--r--dev-libs/librep/librep-0.92.3.ebuild69
-rw-r--r--dev-libs/librep/metadata.xml5
6 files changed, 168 insertions, 0 deletions
diff --git a/dev-libs/librep/Manifest b/dev-libs/librep/Manifest
new file mode 100644
index 000000000000..fcafb6f6bccb
--- /dev/null
+++ b/dev-libs/librep/Manifest
@@ -0,0 +1,2 @@
+DIST librep-0.92.2.1.tar.xz 608988 SHA256 47bb628a377e2c7cb6e22f3e691a88d88af83570ca99b0d7300a5fbcb46b6663 SHA512 7535fbf3af3b6775dfe740623abd09ff48a38641c3be52bbe84ef0b14d37455aa73f3a9941b3a814b04f203664c0e18f1add2111ac968fbf1f59fa4253f6a974 WHIRLPOOL ff59301e924b176e6944a79c1be5635d7d8845a89a06c811cdc891f9edcc4179f555ebbd8092ff0e2194763ab2f554fa224b41b5ec2515468fcfb211b887f747
+DIST librep-0.92.3.tar.xz 607128 SHA256 45c98a5bbdfde4f1d98e3839b319d9ae15857d2d1ae8e3838d9a18d53f3e8b85 SHA512 d65b7a418a2782307c7afa74bba1cc9b690c0fe37938151e7ead3da08cba52d2f5bd2803de22f426b75a353f50287a5ce727c98fc23abbabf9e54b3389f04103 WHIRLPOOL 1ae547f4d795377d77f0fedc67cf3cffc2daf49295798aad088152cdef454c74226e9e9e7f703b0506cd4e1c6cd2b2f321ab8f4cd81f691e1d2d11612cf2c132
diff --git a/dev-libs/librep/files/50librep-gentoo.el b/dev-libs/librep/files/50librep-gentoo.el
new file mode 100644
index 000000000000..59025bbb9d0e
--- /dev/null
+++ b/dev-libs/librep/files/50librep-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; librep site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'rep-debugger "rep-debugger"
+ "Run the rep debugger on program FILE in buffer *gud-FILE*." t)
diff --git a/dev-libs/librep/files/librep-0.92.0-disable-elisp.patch b/dev-libs/librep/files/librep-0.92.0-disable-elisp.patch
new file mode 100644
index 000000000000..6f7b2f1228c7
--- /dev/null
+++ b/dev-libs/librep/files/librep-0.92.0-disable-elisp.patch
@@ -0,0 +1,19 @@
+--- Makefile.in.old 2011-07-25 14:08:18.000000000 +0200
++++ Makefile.in 2011-07-25 14:09:05.000000000 +0200
+@@ -53,15 +53,13 @@
+ $(INSTALL_SCRIPT) libtool $(DESTDIR)$(repcommonexecdir)
+ $(INSTALL_DATA) rules.mk $(DESTDIR)$(repcommonexecdir)
+ $(INSTALL_SCRIPT) install-aliases $(DESTDIR)$(repcommonexecdir)
+- $(INSTALL_DATA) rep-debugger.el $(DESTDIR)$(emacssitelispdir)
+ mkdir -p $(DESTDIR)$(libdir)/pkgconfig
+ $(INSTALL_DATA) $(top_srcdir)/librep.pc $(DESTDIR)$(libdir)/pkgconfig/
+
+ installdirs : mkinstalldirs
+ $(SHELL) $< $(DESTDIR)$(repdir) \
+ $(DESTDIR)$(bindir) $(DESTDIR)$(aclocaldir) \
+- $(DESTDIR)$(repcommonexecdir) $(DESTDIR)$(repexecdir) \
+- $(DESTDIR)$(emacssitelispdir)
++ $(DESTDIR)$(repcommonexecdir) $(DESTDIR)$(repexecdir)
+
+ uninstall :
+ -for dir in $(INSTALL_SUBDIRS); do \
diff --git a/dev-libs/librep/librep-0.92.2.1.ebuild b/dev-libs/librep/librep-0.92.2.1.ebuild
new file mode 100644
index 000000000000..9d934dedbac9
--- /dev/null
+++ b/dev-libs/librep/librep-0.92.2.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils multilib elisp-common
+
+DESCRIPTION="Shared library implementing a Lisp dialect"
+HOMEPAGE="http://librep.sourceforge.net/"
+SRC_URI="http://download.tuxfamily.org/librep/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="emacs readline"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ app-arch/xz-utils"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.92.0-disable-elisp.patch
+}
+
+src_configure() {
+ econf \
+ --libexecdir=/usr/$(get_libdir) \
+ --without-gmp \
+ --without-ffi \
+ --disable-static \
+ $(use_with readline)
+}
+
+src_compile() {
+ emake
+
+ if use emacs; then
+ elisp-compile rep-debugger.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+
+ dodoc ChangeLog MAINTAINERS NEWS README TODO
+ docinto doc
+ dodoc doc/*
+
+ if use emacs; then
+ elisp-install ${PN} rep-debugger.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" \
+ || die "elisp-site-file-install failed"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-libs/librep/librep-0.92.3.ebuild b/dev-libs/librep/librep-0.92.3.ebuild
new file mode 100644
index 000000000000..89cb90206eed
--- /dev/null
+++ b/dev-libs/librep/librep-0.92.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib elisp-common
+
+DESCRIPTION="Shared library implementing a Lisp dialect"
+HOMEPAGE="http://librep.sourceforge.net/"
+SRC_URI="http://download.tuxfamily.org/librep/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="emacs readline"
+
+RDEPEND="
+ >=sys-libs/gdbm-1.8.0
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )
+"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ app-arch/xz-utils
+"
+
+src_prepare() {
+ DOCS="ChangeLog MAINTAINERS NEWS README TODO"
+ epatch "${FILESDIR}"/${PN}-0.92.0-disable-elisp.patch
+}
+
+src_configure() {
+ econf \
+ --libexecdir=/usr/$(get_libdir) \
+ --without-gmp \
+ --without-ffi \
+ --disable-static \
+ $(use_with readline)
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ elisp-compile rep-debugger.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+
+ docinto doc
+ dodoc doc/*
+
+ if use emacs; then
+ elisp-install ${PN} rep-debugger.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" \
+ || die "elisp-site-file-install failed"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-libs/librep/metadata.xml b/dev-libs/librep/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/dev-libs/librep/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>