summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-15 07:18:54 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-15 08:42:48 +0200
commitaaaa49be97b9862adf671aa7d1dcd12fc7965000 (patch)
treec714acdea9312045a668a0edcf6eb0c4e2225498 /dev-libs/librep
parentgentoo/dev-python: Remove old version (diff)
downloadgentoo-aaaa49be97b9862adf671aa7d1dcd12fc7965000.tar.gz
gentoo-aaaa49be97b9862adf671aa7d1dcd12fc7965000.tar.bz2
gentoo-aaaa49be97b9862adf671aa7d1dcd12fc7965000.zip
dev-libs/librep: Version 0.92.7
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-libs/librep')
-rw-r--r--dev-libs/librep/Manifest1
-rw-r--r--dev-libs/librep/librep-0.92.7.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/librep/Manifest b/dev-libs/librep/Manifest
index b1d8ca2f78f2..d8a807e9d3dd 100644
--- a/dev-libs/librep/Manifest
+++ b/dev-libs/librep/Manifest
@@ -1 +1,2 @@
DIST librep_0.92.6.tar.xz 472152 BLAKE2B 165fa8b1d68360e0b08909663cab0f334774030e970c0d376652bc819368eae647882091f1e8d1329f4d3c1c53def4f69aeb8c4d7fe5f327d06d528dc9bb2267 SHA512 6e347e788922af9458e6eddfdaf7935b69df8f70b3f6deb11e6abd67596aec05e7dce7f41db1c84e478347d379ced10cfb34672a797c853913fd538a78a1f96d
+DIST librep_0.92.7.tar.xz 651344 BLAKE2B 3a0e9a3eef0afa2e095537dfc307418ba87ce7a9baabdba262fd9a24b71cc6577fe1282412da495d56bf22007f1931c5b834f5bcf4c5ebe87d6b43a4975d630e SHA512 752cb2da31457200b5896f70ce24a097b261b996da25998cd78a777f982597473afce1a216f449a4a969d29b1678bf54e2f148e86de6f9548eeb5cfd530ae377
diff --git a/dev-libs/librep/librep-0.92.7.ebuild b/dev-libs/librep/librep-0.92.7.ebuild
new file mode 100644
index 000000000000..829d45fb63d6
--- /dev/null
+++ b/dev-libs/librep/librep-0.92.7.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools elisp-common flag-o-matic
+
+DESCRIPTION="Shared library implementing a Lisp dialect"
+HOMEPAGE="https://sawfish.fandom.com/"
+SRC_URI="https://download.tuxfamily.org/librep/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="emacs gmp readline"
+
+RDEPEND="
+ >=sys-libs/gdbm-1.8.0
+ emacs? ( >=app-editors/emacs-23.1:* )
+ gmp? ( dev-libs/gmp:= )
+ readline? ( sys-libs/readline:0= )
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.92.0-disable-elisp.patch
+)
+
+S="${WORKDIR}/${PN}_${PV}"
+
+src_prepare() {
+ # fix #570072 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+ default
+
+ # The configure script is missing from this version.
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with gmp) \
+ $(use_with readline) \
+ --disable-static \
+ --libexecdir=/usr/$(get_libdir) \
+ --without-ffi
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ elisp-compile rep-debugger.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+
+ find "${D}/usr/share/man" -name '*.gz' -exec gunzip {} \; || die
+
+ dodoc doc/*
+
+ if use emacs; then
+ elisp-install ${PN} rep-debugger.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" \
+ || die "elisp-site-file-install failed"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}