summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-01 10:00:51 -0400
committerMatt Turner <mattst88@gentoo.org>2021-05-01 10:06:55 -0400
commit704afae47302a5837f97ec8385e962ff2b08bca0 (patch)
treebb561ad92e71e96aaf37afe445f8e20d886a9878 /dev-libs/libreport
parentdev-libs/satyr: Version bump to 0.37 (diff)
downloadgentoo-704afae47302a5837f97ec8385e962ff2b08bca0.tar.gz
gentoo-704afae47302a5837f97ec8385e962ff2b08bca0.tar.bz2
gentoo-704afae47302a5837f97ec8385e962ff2b08bca0.zip
dev-libs/libreport: Version bump to 2.15.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libreport')
-rw-r--r--dev-libs/libreport/Manifest1
-rw-r--r--dev-libs/libreport/libreport-2.15.0.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-libs/libreport/Manifest b/dev-libs/libreport/Manifest
index da5d5dc33819..1d7fd373044f 100644
--- a/dev-libs/libreport/Manifest
+++ b/dev-libs/libreport/Manifest
@@ -1 +1,2 @@
DIST libreport-2.13.1.tar.gz 1841698 BLAKE2B e0fbebbb557fb9fb320dea0a8face6a2eabdb0ad80b5de092e5e4dfe2a0439a4804d4ec99c1286aaafa31064496a94fabce5e26f851001eb9c3bb9989a46e4bb SHA512 6c2ea47e6efa36f23030fbe08946d1e524690e5f6279cbfdaf7c463ef71b23ae82a5e4471ddce89b35d4024f58197cef9f58a07dfcf5bbc1a9b310e39966f81a
+DIST libreport-2.15.0.tar.gz 1859305 BLAKE2B ceedd392bd0c7fc5c3f0db5d4a63ced6a1e430b09d1d085996ce735daef5f48cd18267fb1401d9343857619daef6f7f3dcea8508c62313a9f908e5573508649c SHA512 7baaa1fb65face910e55ad06e53af08c5e31f058bf5936c3c1d45581e050380b5db75659b5a493cc626a81795d82616a2dfad696d60c107929cfb8e2905e7f4c
diff --git a/dev-libs/libreport/libreport-2.15.0.ebuild b/dev-libs/libreport/libreport-2.15.0.ebuild
new file mode 100644
index 000000000000..886cb5a64cc3
--- /dev/null
+++ b/dev-libs/libreport/libreport-2.15.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Generic library for reporting software bugs"
+HOMEPAGE="https://github.com/abrt/libreport"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk +python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ app-admin/augeas
+ app-arch/libarchive:0=
+ >=dev-libs/glib-2.43.4:2
+ dev-libs/satyr:0=
+ dev-libs/json-c:=
+ dev-libs/libxml2:2
+ dev-libs/nettle:=
+ dev-libs/newt:=
+ dev-libs/xmlrpc-c:=
+ net-libs/libproxy:=
+ net-misc/curl:=[ssl]
+ sys-apps/dbus
+ sys-apps/systemd
+ gtk? ( >=x11-libs/gtk+-3.3.12:3 )
+ python? ( ${PYTHON_DEPS} )
+ x11-misc/xdg-utils
+"
+RDEPEND="${DEPEND}
+ acct-user/abrt
+ acct-group/abrt
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.3.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+# Tests require python-meh, which is highly redhat-specific.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ use python && python_setup
+
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-bugzilla
+ $(use_with gtk)
+ $(use_with python python3)
+ )
+ if use python; then
+ python_foreach_impl run_in_build_dir econf "${myargs[@]}"
+ else
+ econf "${myargs[@]}"
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ else
+ default
+ fi
+}
+
+src_install() {
+ if use python; then
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+ else
+ default
+ fi
+
+ # Need to set correct ownership for use by app-admin/abrt
+ diropts -o abrt -g abrt
+ keepdir /var/spool/abrt
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}