summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-09-27 20:55:12 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-09-27 20:55:12 -0400
commitb3bf0c6e8e827c00f9a5e61173b4e4cb2996c62b (patch)
treea9cb061dec9c494de197a1e49c243344245b87d0 /dev-libs/libressl
parentvirtual/libc: prioritize uclibc-ng over uclibc (diff)
downloadgentoo-b3bf0c6e8e827c00f9a5e61173b4e4cb2996c62b.tar.gz
gentoo-b3bf0c6e8e827c00f9a5e61173b4e4cb2996c62b.tar.bz2
gentoo-b3bf0c6e8e827c00f9a5e61173b4e4cb2996c62b.zip
dev-libs/libressl: version bumps to 2.3.8, 2.4.3, 2.5.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/libressl')
-rw-r--r--dev-libs/libressl/Manifest3
-rw-r--r--dev-libs/libressl/libressl-2.3.8.ebuild51
-rw-r--r--dev-libs/libressl/libressl-2.4.3.ebuild51
-rw-r--r--dev-libs/libressl/libressl-2.5.0.ebuild51
4 files changed, 156 insertions, 0 deletions
diff --git a/dev-libs/libressl/Manifest b/dev-libs/libressl/Manifest
index 21b0d15439df..fc443daf7c8b 100644
--- a/dev-libs/libressl/Manifest
+++ b/dev-libs/libressl/Manifest
@@ -1,2 +1,5 @@
DIST libressl-2.3.7.tar.gz 3013807 SHA256 f59f5d859ce4867cc4761a13d02024f699491e277d54a9fe76e053e5b5f70860 SHA512 5774ab7aa0e4c8f7c61c01192d6c5a782cef57022fcdc64cc61180b4f2ae483145c2e91d56eae78db27dfce04a7ca67fb63e6ce8a8b84b4bc961f65a2a108747 WHIRLPOOL e68251d15a9a2dc9d35b3a4bfd092f7e030d0ba03339f000f201bd297190538368b12324336e5437800bf3b2f481ff739027d30f3f26367ddd48937f35a8f4a3
+DIST libressl-2.3.8.tar.gz 3013999 SHA256 ae6aa4ed2c7d201310fef184310a85c88a315506f633e93fcdeaaec0d5a54fc2 SHA512 5cd99e740894afffa6803087dde4e4207e035bf6f440904fcd4439ca1f63f22bdfe367423b2e95264bef06d1a0f929526d90e623864d0f7e99250a4f825bf282 WHIRLPOOL e4afccd135d0f5cda295e9fe06d81eb0f5fcfb3ffaa18ed2d9a06e5d2fe1c196dc7912eac7e5427f6aa62564f7e6432f00154d5fc11de207da91c6c9d334a254
DIST libressl-2.4.2.tar.gz 3021644 SHA256 5f87d778e5d62822d60e38fa9621c1c5648fc559d198ba314bd9d89cbf67d9e3 SHA512 abacecb318a787f5ef9d8469638b7485fe237d4d993f410d7da8c0773ab8eff8c7da988fe965f793b268711afe599dc28f994eedeaa2aafebeb40faa30af38db WHIRLPOOL a2cdd3109dd200fa9dc4ae0f47f536b2b6d68fd2e53901d4f90a8f39e71af41010d925cd408616f8e5da56f7a8b0397ab21cccca5bfd32ac68ee9bf48ccbb99a
+DIST libressl-2.4.3.tar.gz 3014721 SHA256 bd5726f3e247e7a7d30ce69946d174b8fb92d999d22710c65f176c969812960e SHA512 db3b585ca727eb3e5c5929200c8c86e01559f0d23edcddd6715141e596a3a72a9dd1a69fafda10239def92b586fc582578ecc0bf12bdfbaf083d18e0d3fe5300 WHIRLPOOL eb38d65066e007b7dc88eb26a634c8e45045a8c8a2b5ec19e082607e894b509d1ce93297b77313b1a4f6b12146a22397881e0af78a4e1bff79bfbab55c583c71
+DIST libressl-2.5.0.tar.gz 3012855 SHA256 8652bf6b55ab51fb37b686a3f604a2643e0e8fde2c56e6a936027d12afda6eae SHA512 6372b27f1696e957389646a05b0572ad6936443b34fee0e57153b063831e00318fa1b434e3e0369f0c3df872e15ad3bee2f85db0851021444612f2a6f266a332 WHIRLPOOL 9b145915734a1914f0d36df04a8b35aa2ce2c91f7d6b3a978c5c6845314c56c61718fce6c471ba1a03f3d1ff052246c3db767adee99bc3d38a6bd692b9086ad0
diff --git a/dev-libs/libressl/libressl-2.3.8.ebuild b/dev-libs/libressl/libressl-2.3.8.ebuild
new file mode 100644
index 000000000000..f65fed526d33
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.3.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/38"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
diff --git a/dev-libs/libressl/libressl-2.4.3.ebuild b/dev-libs/libressl/libressl-2.4.3.ebuild
new file mode 100644
index 000000000000..e6602882fd3a
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.4.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/39"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
diff --git a/dev-libs/libressl/libressl-2.5.0.ebuild b/dev-libs/libressl/libressl-2.5.0.ebuild
new file mode 100644
index 000000000000..e6602882fd3a
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/39"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}