summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2019-10-01 07:07:29 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-05-01 18:09:38 +0300
commit4127114ee2cf103b623341ea961cbbda91ed4544 (patch)
tree1315898dc05c8fd126fe9b113e55f4af351ae14c /dev-libs/libsecp256k1
parentx11-terms/kitty: cleanup older versions (diff)
downloadgentoo-4127114ee2cf103b623341ea961cbbda91ed4544.tar.gz
gentoo-4127114ee2cf103b623341ea961cbbda91ed4544.tar.bz2
gentoo-4127114ee2cf103b623341ea961cbbda91ed4544.zip
dev-libs/libsecp256k1: Bump to 0.1_pre20190401
It was released with Bitcoin Core 0.19 Closes: https://bugs.gentoo.org/720118 Signed-off-by: Luke Dashjr <luke-jr+git@utopios.org> Closes: https://github.com/gentoo/gentoo/pull/15573 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/libsecp256k1')
-rw-r--r--dev-libs/libsecp256k1/Manifest1
-rw-r--r--dev-libs/libsecp256k1/libsecp256k1-0.1_pre20190401.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/libsecp256k1/Manifest b/dev-libs/libsecp256k1/Manifest
index 3a923d21740c..1562739aca4f 100644
--- a/dev-libs/libsecp256k1/Manifest
+++ b/dev-libs/libsecp256k1/Manifest
@@ -1,3 +1,4 @@
DIST libsecp256k1-v0.0.0_pre20161213.tgz 147557 BLAKE2B 078cb90c078722e2eb3b5645f9692d737c99ebfe04db5a96dcfb57bb750b31c009cd3ae46f793bb1789239be9689f6e695a5b03477eecea84f2c657d0cc7442c SHA512 f4d16fae972364fd04bfcfbaca1edde4410a7367a936f76c1e93b85ac3c9c45da58785f604a4fc14cdfb4d7a23395d2d274957ad83118e15a236dfff0d0f57dd
DIST libsecp256k1-v0.1_pre20170928.tgz 150935 BLAKE2B f8b3408a33f36186c07cf931a8183a7a241e6418a846f4c3b248cf87e7a8b33a5a92368aa30310efadb066792eebead7fb48b4f4d902e7c8e9b4209717d7b8c0 SHA512 f480c76ba04b3d731c65227e156eb726b27da92f5dcfbd9b0a34c62e97f9b6dfd5c3fae3180b59244d0c9845fdf624b05f29e097f3ac0032ab15cebc4bf00660
+DIST libsecp256k1-v0.1_pre20190401.tgz 166663 BLAKE2B 68c9fc3fda6af56452f32edeae5dcb5a92f68bc3fb39a397c532951c6392347df14ea0347bbe05cab43158512e0d9f5ea87bd8f69bece1b04440860ebb8065ee SHA512 8c4945e93cb5ff241482ba4426b25162a7ae3b26860edc10c91d06b1c396887202ad971f4d38e035828352531b87fc29087a12b675e43da44f23c9ea3b6c0cc8
DIST secp256k1-v0.0.0_pre20151118.tgz 125884 BLAKE2B 7a4fc950006138d04d8d3da35db24be0c568e25202c16f34f94555fde1297fba839fd114a003b5510693de3386de22166c6f1294726fe381ae5b565cb9866a75 SHA512 3cc0a4973acf7936a7c6dc0abc37ee43ecd69e835069ed40765595d36ca597b43837b5d6f90499455599de03abfc775d7c9d019d26216b79b03dd6dc53a73e19
diff --git a/dev-libs/libsecp256k1/libsecp256k1-0.1_pre20190401.ebuild b/dev-libs/libsecp256k1/libsecp256k1-0.1_pre20190401.ebuild
new file mode 100644
index 000000000000..330a5cdd9972
--- /dev/null
+++ b/dev-libs/libsecp256k1/libsecp256k1-0.1_pre20190401.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MyPN=secp256k1
+DESCRIPTION="Optimized C library for EC operations on curve secp256k1"
+HOMEPAGE="https://github.com/bitcoin-core/secp256k1"
+COMMITHASH="b19c000063be11018b4d1a6b0a85871ab9d0bdcf"
+SRC_URI="https://github.com/bitcoin-core/${MyPN}/archive/${COMMITHASH}.tar.gz -> ${PN}-v${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+asm ecdh endomorphism experimental gmp java +recovery test test-openssl"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ asm? ( || ( amd64 arm ) arm? ( experimental ) )
+ ecdh? ( experimental )
+ java? ( ecdh )
+ test-openssl? ( test )
+"
+RDEPEND="
+ gmp? ( dev-libs/gmp:0= )
+"
+DEPEND="${RDEPEND}
+ java? ( virtual/jdk )
+ test-openssl? ( dev-libs/openssl:0 )
+"
+BDEPEND="
+ java? ( virtual/jdk )
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MyPN}-${COMMITHASH}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local asm_opt
+ if use asm; then
+ if use arm; then
+ asm_opt=arm
+ else
+ asm_opt=auto
+ fi
+ else
+ asm_opt=no
+ fi
+ econf \
+ --disable-benchmark \
+ $(use_enable experimental) \
+ $(use_enable java jni) \
+ $(use_enable test tests) \
+ $(use_enable test-openssl openssl-tests) \
+ $(use_enable ecdh module-ecdh) \
+ $(use_enable endomorphism) \
+ --with-asm=$asm_opt \
+ --with-bignum=$(usex gmp gmp no) \
+ $(use_enable recovery module-recovery) \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}