summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-03-13 14:50:58 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-03-13 14:50:58 +0100
commit529b544e37af85773dbe5f74f4ee1b7b02d66e9f (patch)
tree8639501fd2c5a7ae9ef3bbe36887411e5029ff18 /dev-libs/libsodium/libsodium-1.0.12.ebuild
parentdev-util/cookiecutter: Add python3_5 support (diff)
downloadgentoo-529b544e37af85773dbe5f74f4ee1b7b02d66e9f.tar.gz
gentoo-529b544e37af85773dbe5f74f4ee1b7b02d66e9f.tar.bz2
gentoo-529b544e37af85773dbe5f74f4ee1b7b02d66e9f.zip
dev-libs/libsodium: Version bump to 1.0.12
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-libs/libsodium/libsodium-1.0.12.ebuild')
-rw-r--r--dev-libs/libsodium/libsodium-1.0.12.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libsodium/libsodium-1.0.12.ebuild b/dev-libs/libsodium/libsodium-1.0.12.ebuild
new file mode 100644
index 000000000000..2b80cec2ea29
--- /dev/null
+++ b/dev-libs/libsodium/libsodium-1.0.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
+HOMEPAGE="https://github.com/jedisct1/libsodium"
+SRC_URI="http://download.libsodium.org/${PN}/releases/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/18"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+asm minimal static-libs +urandom cpu_flags_x86_sse4_1 cpu_flags_x86_aes"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0.10-cpuflags.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # --disable-pie needed on x86, bug #512734
+ use x86 && myconf="${myconf} --disable-pie"
+
+ econf \
+ $(use_enable asm) \
+ $(use_enable minimal) \
+ $(use_enable !urandom blocking-random) \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_sse4_1 sse4_1) \
+ $(use_enable cpu_flags_x86_aes aesni) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}