summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-10-02 17:29:16 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-10-02 17:29:42 +0200
commitec8a3697683ee3f6314fe1d6ccc30c9486a3706a (patch)
tree54b1d94fcf9c86314f0afe198e12464d6a982851 /dev-libs/libsodium/libsodium-1.0.15.ebuild
parentdev-db/mariadb: Move --user bootstrap option to later in the commands (diff)
downloadgentoo-ec8a3697683ee3f6314fe1d6ccc30c9486a3706a.tar.gz
gentoo-ec8a3697683ee3f6314fe1d6ccc30c9486a3706a.tar.bz2
gentoo-ec8a3697683ee3f6314fe1d6ccc30c9486a3706a.zip
dev-libs/libsodium: Version bump to 1.0.15
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libsodium/libsodium-1.0.15.ebuild')
-rw-r--r--dev-libs/libsodium/libsodium-1.0.15.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libsodium/libsodium-1.0.15.ebuild b/dev-libs/libsodium/libsodium-1.0.15.ebuild
new file mode 100644
index 000000000000..d4089d0a895d
--- /dev/null
+++ b/dev-libs/libsodium/libsodium-1.0.15.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
+HOMEPAGE="https://github.com/jedisct1/libsodium"
+SRC_URI="http://download.libsodium.org/${PN}/releases/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/23"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+asm minimal static-libs +urandom cpu_flags_x86_sse4_1 cpu_flags_x86_aes"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0.10-cpuflags.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # --disable-pie needed on x86, bug #512734
+ use x86 && myconf="${myconf} --disable-pie"
+
+ econf \
+ $(use_enable asm) \
+ $(use_enable minimal) \
+ $(use_enable !urandom blocking-random) \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_sse4_1 sse4_1) \
+ $(use_enable cpu_flags_x86_aes aesni) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}