summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2019-10-05 14:21:21 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-10-09 08:21:24 +0300
commite01960bb1156fcbd7d5647c68a2c359316bb41b6 (patch)
tree4c3b8a5b6a5cb9284578eab27dce3a3fe065d09d /dev-libs/libuev
parentnet-analyzer/sslsplit: version bump to 0.5.5 (diff)
downloadgentoo-e01960bb1156fcbd7d5647c68a2c359316bb41b6.tar.gz
gentoo-e01960bb1156fcbd7d5647c68a2c359316bb41b6.tar.bz2
gentoo-e01960bb1156fcbd7d5647c68a2c359316bb41b6.zip
dev-libs/libuev: bump version to 2.3.0
Closes: https://bugs.gentoo.org/696550 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13167 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/libuev')
-rw-r--r--dev-libs/libuev/Manifest1
-rw-r--r--dev-libs/libuev/libuev-2.3.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/libuev/Manifest b/dev-libs/libuev/Manifest
index 03a55d1c5d5b..77cc86873a78 100644
--- a/dev-libs/libuev/Manifest
+++ b/dev-libs/libuev/Manifest
@@ -1,3 +1,4 @@
DIST libuev-2.1.0.tar.xz 247388 BLAKE2B e2934fb79e32bf61e22a7c8fcdd6371f089c5e8a4f5b3039c10c90abd852d08c5612f7b871ef705afdca68857a270dfd133a1436cd9f49876e0bf47b903e6328 SHA512 82bd68c75f015284d3757886720d1a0e5689cf71b40b896410e5e4e952761fe05b090a33e0787f632afa7726567667e4dbbbc6270129828656953ded6d28d02b
DIST libuev-2.1.2.tar.xz 248092 BLAKE2B 7229acc6ae0e55a5ceba00e970a9e7b4b11049dc4f4435643e0541a7b3c75ac300ffc2839da0eaa7b3819a5910d20b608247812d32c028ff19c0cf3735d2941c SHA512 65a35f1e2cda5383267ba47bc90e2cdd769e5fb1318c11969c8f44262d8a5b2edad522688619aa6e9219c278286ba9ff997967f9281aa4f667fbe9b0842bf0ee
DIST libuev-2.2.0.tar.xz 245680 BLAKE2B 40d0912dcec56d58863411e034c6ddded3470bc2ea3a9f49d36fa0ef924e9ff206cb96ef93582134881ce8377938688d44cfa04d7e533321baf7cfd754f0dff0 SHA512 700c91100c61af2101a6d1756eed97aaf51d6b1dc3a59f90f668d8bb6e3d817aa6f765af5acbbdaeccd4382a97c8e99d2a13ad679fc8582891e0546baa6f001f
+DIST libuev-2.3.0.tar.xz 247932 BLAKE2B dea136cbd34788b7156a5ce1b8390467fde77a21b6fb4c7b27068b87254eb42034579bcaed3228dcfacd00b320668db915557230ebbb8da9487ade2359a5fabe SHA512 dc6cd2d1df5336027d8df77fda17b9d9521d955ffa013a5e83958d6b4f981f14f5b0caac3e68e4fa4a8a00bbe8001a18de54ebc441b4231a2d17600c762f80d2
diff --git a/dev-libs/libuev/libuev-2.3.0.ebuild b/dev-libs/libuev/libuev-2.3.0.ebuild
new file mode 100644
index 000000000000..2980b3bbb0e2
--- /dev/null
+++ b/dev-libs/libuev/libuev-2.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A collection of useful BSD APIs"
+HOMEPAGE="https://github.com/troglobit/libuev"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure(){
+ econf --enable-static=$(usex static-libs)
+}
+
+src_install(){
+ default
+ find "${D}" -name '*.la' -delete || die
+ rm "${D}/usr/share/doc/${PF}/LICENSE" || die
+}