summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-11-30 16:56:45 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-11-30 16:56:45 +0700
commitab1a2dd83007e53a58bc11a46b87e41b220f7c80 (patch)
tree8935cab4a0a884be1262219cb6f60c81b9b9b535 /dev-libs/libunibreak
parentdev-libs/libclc: 13.x branch is now 13.0.1 (diff)
downloadgentoo-ab1a2dd83007e53a58bc11a46b87e41b220f7c80.tar.gz
gentoo-ab1a2dd83007e53a58bc11a46b87e41b220f7c80.tar.bz2
gentoo-ab1a2dd83007e53a58bc11a46b87e41b220f7c80.zip
dev-libs/libunibreak: bump to 5.0
Closes: https://bugs.gentoo.org/827865 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-libs/libunibreak')
-rw-r--r--dev-libs/libunibreak/Manifest1
-rw-r--r--dev-libs/libunibreak/libunibreak-5.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/libunibreak/Manifest b/dev-libs/libunibreak/Manifest
index 5959d3c3396a..1131c417eabd 100644
--- a/dev-libs/libunibreak/Manifest
+++ b/dev-libs/libunibreak/Manifest
@@ -1 +1,2 @@
DIST libunibreak-4.3.tar.gz 639886 BLAKE2B ec044b659f1a837b4e6627067b96a6f19ee8302602d635e1e32aab9533486b5cd063aa99114c6443ede9d76d3f382d7492eac8b52b84a4baa2ccd9c2129e79d8 SHA512 4b53fd169912033403b6ca09047b7b928211fab3607ef26070ab731054138b9a291f7d138d3a479f9cde8edb0fabf8da114da68aee32e60cddf45cc3baae1170
+DIST libunibreak-5.0.tar.gz 664105 BLAKE2B 4755f77da7aeece8e43f121e35124f85afa31740394cecc1a192d0b284d8d683765a6a38898f5ffd8a567e2d65a086fdc25a816a77337f242df7be5c14ae6e98 SHA512 33ce584208fea1f2f22dcc49592a467b0fdc04a8b9ed80c97d7ce2058e8d6c919b4a173c9ec3ca38411ffa497d95d2abe207dfc09866f9fcba125867015cf9fb
diff --git a/dev-libs/libunibreak/libunibreak-5.0.ebuild b/dev-libs/libunibreak/libunibreak-5.0.ebuild
new file mode 100644
index 000000000000..f4466edceb68
--- /dev/null
+++ b/dev-libs/libunibreak/libunibreak-5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Line and word breaking library"
+HOMEPAGE="http://vimgadgets.sourceforge.net/libunibreak/"
+SRC_URI="https://github.com/adah1972/${PN}/releases/download/${PN}_$(ver_rs 1- '_')/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc +man static-libs"
+
+# Tests require internet access to www.unicode.org
+RESTRICT="test"
+
+BDEPEND="man? ( app-doc/doxygen )"
+
+src_prepare() {
+ if use man; then
+ echo 'GENERATE_MAN=YES' >> Doxyfile || die
+ echo 'GENERATE_HTML=NO' >> Doxyfile || die
+ fi
+ default
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ if use man; then
+ doxygen || die 'doxygen failed'
+ pushd "${S}"/doc/man > /dev/null
+ mv man3 x || die
+ mkdir man3 || die
+ for h in graphemebreak linebreak linebreakdef unibreakbase unibreakdef wordbreak; do
+ mv x/${h}.h.3 man3/ || die "man ${h} not found"
+ done
+ rm -rf x || die
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/html/. )
+ default
+ find "${D}" -name '*.la' -delete || die
+ if use man; then
+ doman doc/man/man3/*.3
+ fi
+}