summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-30 12:22:31 +0100
committerMichał Górny <mgorny@gentoo.org>2018-11-10 20:18:03 +0100
commitc07389aed20a989506465a2af7f101ab751f6c51 (patch)
tree62183e8657e3dc71110e13efd43b6090093c9145 /dev-libs/libuninum
parentkde5-functions.eclass: Drop obsolete kde-plasma-5.12 minimum deps (diff)
downloadgentoo-c07389aed20a989506465a2af7f101ab751f6c51.tar.gz
gentoo-c07389aed20a989506465a2af7f101ab751f6c51.tar.bz2
gentoo-c07389aed20a989506465a2af7f101ab751f6c51.zip
dev-libs/libuninum: New package
This is a library for converting unicode strings to numbers and numbers to unicode strings. Closes: https://bugs.gentoo.org/667154 Needed-by: https://bugs.gentoo.org/154528 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libuninum')
-rw-r--r--dev-libs/libuninum/Manifest1
-rw-r--r--dev-libs/libuninum/libuninum-2.7.ebuild26
-rw-r--r--dev-libs/libuninum/metadata.xml18
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libuninum/Manifest b/dev-libs/libuninum/Manifest
new file mode 100644
index 000000000000..5ce8368c044c
--- /dev/null
+++ b/dev-libs/libuninum/Manifest
@@ -0,0 +1 @@
+DIST libuninum-2.7.tar.bz2 276712 BLAKE2B 0894c632d7e9081f35d543895809bcc04fde6da674d4e6adc7cdc914f4bbb257a3e683b381e6496a08b65790731f73315d8263970265a351f40fe504f210c883 SHA512 4536a90b9f34fbabd3cc0560c1ff385063151bc381de51e6ca0253d2a42c2290b92329795b1a12ade305c3cb5757b02fe9d92817829977f50da2e34852936274
diff --git a/dev-libs/libuninum/libuninum-2.7.ebuild b/dev-libs/libuninum/libuninum-2.7.ebuild
new file mode 100644
index 000000000000..2d661dff563d
--- /dev/null
+++ b/dev-libs/libuninum/libuninum-2.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A library for converting unicode strings to numbers and vice versa"
+HOMEPAGE="https://billposer.org/Software/libuninum.html"
+SRC_URI="https://billposer.org/Software/Downloads/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2 GPL-2+ LGPL-2 LGPL-2.1"
+SLOT="0"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libuninum/metadata.xml b/dev-libs/libuninum/metadata.xml
new file mode 100644
index 000000000000..0db8928175d3
--- /dev/null
+++ b/dev-libs/libuninum/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ This is a library for converting unicode strings to numbers and numbers to unicode strings.
+ Standard functions like strtoul, strtod, and sprintf do this for numbers written in the
+ usual western number system using the indo-arabic numerals, but they do not handle other number systems.
+ The main functions take as input a UTF-32 unicode string and compute the corresponding unsigned integer.
+ </longdescription>
+</pkgmetadata>