summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-04-21 15:17:24 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-04-21 15:18:46 -0400
commit98de6f326806181db1d06969800a009e7c53824c (patch)
tree91f061b1d11801178ce8b4a5044751ea23b78be0 /dev-libs/libutf8proc
parentapp-i18n/unicode-data: bump to 12.0.0 (diff)
downloadgentoo-98de6f326806181db1d06969800a009e7c53824c.tar.gz
gentoo-98de6f326806181db1d06969800a009e7c53824c.tar.bz2
gentoo-98de6f326806181db1d06969800a009e7c53824c.zip
dev-libs/libutf8proc: don't access internet during tests
Patch the test data makefile to use app-i18n/unicode-data instead of fetching unicode data from the internet. Closes: https://bugs.gentoo.org/682812 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-libs/libutf8proc')
-rw-r--r--dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch33
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild6
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch
new file mode 100644
index 000000000000..5750b43ad5fc
--- /dev/null
+++ b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch
@@ -0,0 +1,33 @@
+diff --git a/data/Makefile b/data/Makefile
+index f5d1dd9..60c09e3 100644
+--- a/data/Makefile
++++ b/data/Makefile
+@@ -10,6 +10,7 @@ PERL=perl
+ MAKE=make
+ JULIA=julia
+ CURLFLAGS = --retry 5 --location
++UDATA=/usr/share/unicode-data
+
+ .PHONY: clean
+
+@@ -25,6 +26,7 @@ CharWidths.txt: charwidths.jl EastAsianWidth.txt
+ UNICODE_VERSION=12.0.0
+
+ UnicodeData.txt:
++ cp $(UDATA)/$@ $@
+ $(CURL) $(CURLFLAGS) -o $@ -O http://www.unicode.org/Public/$(UNICODE_VERSION)/ucd/UnicodeData.txt
+
+ EastAsianWidth.txt:
+@@ -43,10 +45,10 @@ CaseFolding.txt:
+ $(CURL) $(CURLFLAGS) -o $@ -O $(URLCACHE)http://www.unicode.org/Public/$(UNICODE_VERSION)/ucd/CaseFolding.txt
+
+ NormalizationTest.txt:
+- $(CURL) $(CURLFLAGS) -o $@ -O $(URLCACHE)http://www.unicode.org/Public/$(UNICODE_VERSION)/ucd/NormalizationTest.txt
++ cp $(UDATA)/$@ $@
+
+ GraphemeBreakTest.txt:
+- $(CURL) $(CURLFLAGS) $(URLCACHE)http://www.unicode.org/Public/$(UNICODE_VERSION)/ucd/auxiliary/GraphemeBreakTest.txt | $(PERL) -pe 's,÷,/,g;s,×,+,g' > $@
++ cat $(UDATA)/auxiliary/$@ | $(PERL) -pe 's,÷,/,g;s,×,+,g' > $@
+
+ emoji-data.txt:
+ $(CURL) $(CURLFLAGS) -o $@ -O $(URLCACHE)http://unicode.org/Public/emoji/`echo $(UNICODE_VERSION) | cut -d. -f1-2`/emoji-data.txt
diff --git a/dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild b/dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild
index ea48c910201a..3b3b3a532031 100644
--- a/dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild
+++ b/dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild
@@ -13,13 +13,17 @@ SRC_URI="https://github.com/JuliaStrings/utf8proc/archive/v${PV}.tar.gz -> ${P}.
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="test"
S="${WORKDIR}/${MY_P}"
+BDEPEND="test? ( =app-i18n/unicode-data-12.0* )"
+
PATCHES=(
# Don't build or install static libs
"${FILESDIR}/${PN}-2.3.0-no-static.patch"
+ # use app-i18n/unicode-data for test data instead of curl
+ "${FILESDIR}/${PN}-2.3.0-tests-nofetch.patch"
)
src_install() {