summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2018-12-15 16:04:49 +0300
committerEray Aslan <eras@gentoo.org>2018-12-15 16:04:49 +0300
commit5b6faf1954ea6d10706b6fce3f4b7e946a4bc90c (patch)
treeea47edec0edbb959d1967735e7d5da81fcd8503e /dev-libs/libverto/files
parentmedia-video/gpac: stable 0.7.1-r1 for sparc, bug #669966 (diff)
downloadgentoo-5b6faf1954ea6d10706b6fce3f4b7e946a4bc90c.tar.gz
gentoo-5b6faf1954ea6d10706b6fce3f4b7e946a4bc90c.tar.bz2
gentoo-5b6faf1954ea6d10706b6fce3f4b7e946a4bc90c.zip
dev-libs/libverto: bump to 0.3.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Eray Aslan <eras@gentoo.org>
Diffstat (limited to 'dev-libs/libverto/files')
-rw-r--r--dev-libs/libverto/files/libverto-Wflags.patch25
-rw-r--r--dev-libs/libverto/files/libverto-libev-c89.patch15
-rw-r--r--dev-libs/libverto/files/libverto-load.patch78
-rw-r--r--dev-libs/libverto/files/libverto-verify-cflags.patch26
4 files changed, 144 insertions, 0 deletions
diff --git a/dev-libs/libverto/files/libverto-Wflags.patch b/dev-libs/libverto/files/libverto-Wflags.patch
new file mode 100644
index 000000000000..de403720dd62
--- /dev/null
+++ b/dev-libs/libverto/files/libverto-Wflags.patch
@@ -0,0 +1,25 @@
+From f3935464e3a823539394dcb4669a6e7a889a95ef Mon Sep 17 00:00:00 2001
+From: Robbie Harwood <rharwood@redhat.com>
+Date: Wed, 31 Jan 2018 18:21:04 +0100
+Subject: [PATCH] Turn off -Wcast-function-type
+
+The glib event library forces all callbacks to the same type, even
+when they have different arities. Turn off the gcc warning for this
+gross behavior.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4084965..dcab593 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,7 +9,7 @@ m4_ifdef([AC_USE_SYSTEM_EXTENSIONS],
+
+ AC_PROG_CC_C99
+
+-for flag in -Wall -Wextra; do
++for flag in -Wall -Wextra -Wno-cast-function-type; do
+ OLD_CFLAGS=$CFLAGS
+ CFLAGS="$CFLAGS $flag"
+ AC_TRY_COMPILE(, [return 0;], [], [CFLAGS=$OLD_CFLAGS])
diff --git a/dev-libs/libverto/files/libverto-libev-c89.patch b/dev-libs/libverto/files/libverto-libev-c89.patch
new file mode 100644
index 000000000000..e63c032b0c89
--- /dev/null
+++ b/dev-libs/libverto/files/libverto-libev-c89.patch
@@ -0,0 +1,15 @@
+diff --git a/configure.ac b/configure.ac
+index 09ee123..b7b5908 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -7,8 +7,8 @@ m4_ifdef([AC_USE_SYSTEM_EXTENSIONS],
+ [AC_USE_SYSTEM_EXTENSIONS],
+ [AC_GNU_SOURCE])
+
+-AC_PROG_CC_C89
+-for flag in -std=c89 -Wall -Wextra; do
++AC_PROG_CC_C99
++for flag in -Wall -Wextra; do
+ AC_TRY_COMPILE([], [return 0;], [CFLAGS="$CFLAGS $flag"],)
+ done
+
diff --git a/dev-libs/libverto/files/libverto-load.patch b/dev-libs/libverto/files/libverto-load.patch
new file mode 100644
index 000000000000..94dceac5d69c
--- /dev/null
+++ b/dev-libs/libverto/files/libverto-load.patch
@@ -0,0 +1,78 @@
+From 7989b3c6bdfdeb8770d17d8717b4a0cd48e79386 Mon Sep 17 00:00:00 2001
+From: Robbie Harwood <rharwood@redhat.com>
+Date: Wed, 24 Oct 2018 16:57:11 -0400
+Subject: [PATCH] Fix rare leak of DSO in module_load
+
+---
+ src/module.c | 31 +++++++++++++++----------------
+ 1 file changed, 15 insertions(+), 16 deletions(-)
+
+diff --git a/src/module.c b/src/module.c
+index 1f1b7c9..0b59034 100644
+--- a/src/module.c
++++ b/src/module.c
+@@ -182,7 +182,7 @@ module_load(const char *filename, const char *symbname,
+ intdll = dlopen(filename, RTLD_LAZY | RTLD_LOCAL);
+ #endif /* WIN32 */
+ if (!intdll)
+- return dllerror();
++ goto fail;
+
+ /* Get the module symbol */
+ #ifdef WIN32
+@@ -190,16 +190,12 @@ module_load(const char *filename, const char *symbname,
+ #else /* WIN32 */
+ intsym = dlsym(intdll, symbname);
+ #endif /* WIN32 */
+- if (!intsym) {
+- module_close(intdll);
+- return dllerror();
+- }
++ if (!intsym)
++ goto fail;
+
+ /* Figure out whether or not to load this module */
+- if (!shouldload(intsym, misc, &interr)) {
+- module_close(intdll);
+- return interr;
+- }
++ if (!shouldload(intsym, misc, &interr))
++ goto fail;
+
+ /* Re-open the module */
+ module_close(intdll);
+@@ -208,9 +204,8 @@ module_load(const char *filename, const char *symbname,
+ #else /* WIN32 */
+ intdll = dlopen(filename, RTLD_NOW | RTLD_LOCAL);
+ #endif /* WIN32 */
+- if (!intdll) {
+- return dllerror();
+- }
++ if (!intdll)
++ goto fail;
+
+ /* Get the symbol again */
+ #ifdef WIN32
+@@ -218,14 +213,18 @@ module_load(const char *filename, const char *symbname,
+ #else /* WIN32 */
+ intsym = dlsym(intdll, symbname);
+ #endif /* WIN32 */
+- if (!intsym) {
+- module_close(intdll);
+- return dllerror();
+- }
++ if (!intsym)
++ goto fail;
+
+ if (dll)
+ *dll = intdll;
+ if (symb)
+ *symb = intsym;
+ return NULL;
++
++fail:
++ if (!interr)
++ interr = dllerror();
++ module_close(intdll);
++ return interr;
+ }
diff --git a/dev-libs/libverto/files/libverto-verify-cflags.patch b/dev-libs/libverto/files/libverto-verify-cflags.patch
new file mode 100644
index 000000000000..dce747239dc7
--- /dev/null
+++ b/dev-libs/libverto/files/libverto-verify-cflags.patch
@@ -0,0 +1,26 @@
+From 5bbe8b009d6daa809f679fd1d25c270abba468b4 Mon Sep 17 00:00:00 2001
+From: Robbie Harwood <rharwood@redhat.com>
+Date: Wed, 31 Jan 2018 17:52:39 +0100
+Subject: [PATCH] Verify flags prior to adding them to CFLAGS, not after
+
+---
+ configure.ac | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index b7b5908..4084965 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -8,8 +8,11 @@ m4_ifdef([AC_USE_SYSTEM_EXTENSIONS],
+ [AC_GNU_SOURCE])
+
+ AC_PROG_CC_C99
++
+ for flag in -Wall -Wextra; do
+- AC_TRY_COMPILE([], [return 0;], [CFLAGS="$CFLAGS $flag"],)
++ OLD_CFLAGS=$CFLAGS
++ CFLAGS="$CFLAGS $flag"
++ AC_TRY_COMPILE(, [return 0;], [], [CFLAGS=$OLD_CFLAGS])
+ done
+
+ AC_CANONICAL_SYSTEM