summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-09-24 23:52:28 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-09-25 00:09:46 +0200
commitc3626a6f36ffb6d526337b51f2e89ab2f22cec52 (patch)
treeb6ee5c08cd2d204162b58f865a258537e33b92cc /dev-libs/libxmlb
parentdev-python/PyQt5: add 5.13.1 (diff)
downloadgentoo-c3626a6f36ffb6d526337b51f2e89ab2f22cec52.tar.gz
gentoo-c3626a6f36ffb6d526337b51f2e89ab2f22cec52.tar.bz2
gentoo-c3626a6f36ffb6d526337b51f2e89ab2f22cec52.zip
dev-libs/libxmlb: fix Python dependency
Closes: https://bugs.gentoo.org/692904 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/libxmlb')
-rw-r--r--dev-libs/libxmlb/libxmlb-0.1.11.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/dev-libs/libxmlb/libxmlb-0.1.11.ebuild b/dev-libs/libxmlb/libxmlb-0.1.11.ebuild
index 487a34f0da43..51a1b304f84c 100644
--- a/dev-libs/libxmlb/libxmlb-0.1.11.ebuild
+++ b/dev-libs/libxmlb/libxmlb-0.1.11.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit meson
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit meson python-any-r1
DESCRIPTION="Library to help create and query binary XML blobs"
HOMEPAGE="https://github.com/hughsie/libxmlb"
@@ -29,8 +31,20 @@ DEPEND="
BDEPEND="
>=dev-util/meson-0.47.0
virtual/pkgconfig
+ introspection? (
+ $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+ )
"
+python_check_deps() {
+ has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use introspection && python-any-r1_pkg_setup
+}
+
src_configure() {
local emesonargs=(
-Dgtkdoc="$(usex doc true false)"