summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/lockdev/lockdev-1.0.3.1.2-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/lockdev/lockdev-1.0.3.1.2-r3.ebuild')
-rw-r--r--dev-libs/lockdev/lockdev-1.0.3.1.2-r3.ebuild104
1 files changed, 104 insertions, 0 deletions
diff --git a/dev-libs/lockdev/lockdev-1.0.3.1.2-r3.ebuild b/dev-libs/lockdev/lockdev-1.0.3.1.2-r3.ebuild
new file mode 100644
index 000000000000..6ce8e67344ab
--- /dev/null
+++ b/dev-libs/lockdev/lockdev-1.0.3.1.2-r3.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL="no"
+inherit toolchain-funcs perl-module eutils versionator autotools multilib-minimal
+
+MAJOR=$(get_major_version)
+MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
+DEB_PV=$(replace_version_separator 3 '-')
+DEB_P=${PN}_${DEB_PV}
+
+DESCRIPTION="Library for locking devices"
+HOMEPAGE="http://packages.debian.org/source/sid/lockdev"
+SRC_URI="
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${DEB_P}.diff.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="perl"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${MY_P}-add-autotools.patch"
+ "${FILESDIR}/${MY_P}-fix-perl.patch"
+)
+
+S=${WORKDIR}/${PN}-${MY_PV}
+PERL_S=./LockDev
+
+pkg_setup() {
+ use perl && perl_set_version
+}
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ # Note: we do *not* want to be in ${S} for this, as that breaks the patch
+ epatch "${WORKDIR}/${DEB_P}.diff"
+
+ cd "${S}" || die
+ epatch "${PATCHES[@]}"
+ epatch_user
+
+ eautoreconf
+
+ # perl module build
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf
+
+ if multilib_is_native_abi && use perl; then
+ cd "${PERL_S}" || die
+ perl-module_src_configure
+ fi
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use perl; then
+ cd "${PERL_S}" || die
+ perl-module_src_compile
+ fi
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi && use perl; then
+ cd "${PERL_S}" || die
+ SRC_TEST="do"
+ export LD_LIBRARY_PATH="${LD_LIBRARY_PATH:+${LD_LIBRARY_PATH}:}${BUILD_DIR}/.libs"
+ perl-module_src_test
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use perl; then
+ cd "${PERL_S}" || die
+ mytargets="pure_install"
+ perl-module_src_install
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS ChangeLog* debian/NEWS README.debug
+ newdoc debian/changelog changelog.debian
+
+ prune_libtool_files --all
+}
+
+pkg_preinst() {
+ use perl && perl_set_version
+}