summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-16 00:23:04 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-16 00:23:04 +0100
commit257e0368734cf224b0b94cdf56bd59af2e97042e (patch)
treea3b31d513aaacd93c29b2655fc15289f0e132e45 /dev-libs/log4cxx
parentdev-libs/libpo6: disable static libs (diff)
downloadgentoo-257e0368734cf224b0b94cdf56bd59af2e97042e.tar.gz
gentoo-257e0368734cf224b0b94cdf56bd59af2e97042e.tar.bz2
gentoo-257e0368734cf224b0b94cdf56bd59af2e97042e.zip
dev-libs/log4cxx: disable static libs
Closes: https://bugs.gentoo.org/726998 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/log4cxx')
-rw-r--r--dev-libs/log4cxx/log4cxx-0.10.0-r1.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/dev-libs/log4cxx/log4cxx-0.10.0-r1.ebuild b/dev-libs/log4cxx/log4cxx-0.10.0-r1.ebuild
index a1756aaab0f3..adc8b749d16b 100644
--- a/dev-libs/log4cxx/log4cxx-0.10.0-r1.ebuild
+++ b/dev-libs/log4cxx/log4cxx-0.10.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
MY_P=apache-${P}
@@ -13,26 +13,27 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos"
IUSE="iodbc unicode odbc smtp"
+# test suite fails
+RESTRICT="test"
-RDEPEND="dev-libs/apr:1
+RDEPEND="
+ dev-libs/apr:1
dev-libs/apr-util:1
odbc? (
iodbc? ( >=dev-db/libiodbc-3.52.4 )
- !iodbc? ( dev-db/unixODBC ) )
+ !iodbc? ( dev-db/unixODBC )
+ )
smtp? ( net-libs/libesmtp )"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
-# test suite fails
-RESTRICT="test"
-
HTML_DOCS=( site/. )
PATCHES=(
- "${FILESDIR}/${PN}-0.10.0-missing_includes.patch"
- "${FILESDIR}/${PN}-0.10.0-gcc44.patch"
- "${FILESDIR}/${PN}-0.10.0-unixODBC.patch"
- "${FILESDIR}/${PN}-0.10.0-fix-c++14.patch"
+ "${FILESDIR}"/${PN}-0.10.0-missing_includes.patch
+ "${FILESDIR}"/${PN}-0.10.0-gcc44.patch
+ "${FILESDIR}"/${PN}-0.10.0-unixODBC.patch
+ "${FILESDIR}"/${PN}-0.10.0-fix-c++14.patch
)
pkg_setup() {
@@ -43,9 +44,10 @@ pkg_setup() {
src_configure() {
econf \
+ --disable-static \
--disable-doxygen \
--disable-html-docs \
- --with-apr-util="${SYSROOT}${EPREFIX}/usr" \
+ --with-apr-util="${ESYSROOT}"/usr \
$(use_with smtp SMTP libesmtp) \
$(use_with odbc ODBC $(usex iodbc iODBC unixODBC)) \
--with-charset=$(usex unicode utf-8 auto)
@@ -59,5 +61,5 @@ src_install() {
docompress -x /usr/share/doc/${PF}/examples
# package provides .pc files
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}