summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/luise-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/luise-bin')
-rw-r--r--dev-libs/luise-bin/Manifest1
-rw-r--r--dev-libs/luise-bin/luise-bin-0.1.1.ebuild41
-rw-r--r--dev-libs/luise-bin/metadata.xml7
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/luise-bin/Manifest b/dev-libs/luise-bin/Manifest
new file mode 100644
index 000000000000..96418eb353de
--- /dev/null
+++ b/dev-libs/luise-bin/Manifest
@@ -0,0 +1 @@
+DIST LUIse_0.1.1.tar.gz 393815 SHA256 c197a82d3b043d40b3d1ebbe2aa5ed7e7b74955bbc1d2316657fd8e27ce16ed0 SHA512 821b62ed476088c3818cb478a3c525e1d92e9879ef4059da0eb534852a294f802550ad7169066fe439f0cb3645e98656f405594db633061029ae9d7eff86f31d WHIRLPOOL 29d76837651ca691294a559ede2b0fdb365ac2cfd1060602042b0e339655080cf1e264e47dceb6df7b7476d455f3097361566ff2b2ee9a231545cb2a151e9b50
diff --git a/dev-libs/luise-bin/luise-bin-0.1.1.ebuild b/dev-libs/luise-bin/luise-bin-0.1.1.ebuild
new file mode 100644
index 000000000000..cd92acd369e9
--- /dev/null
+++ b/dev-libs/luise-bin/luise-bin-0.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit multilib
+
+MY_PN="LUIse"
+
+DESCRIPTION="Programming interface for the Wallbraun LCD-USB-Interface"
+HOMEPAGE="http://wallbraun-electronics.de/downloadssite/"
+SRC_URI="http://www.wallbraun-electronics.de/downloads/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="doc examples"
+
+DEPEND="=virtual/libusb-0*"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}_${PV}"
+src_install() {
+ if use x86 ; then
+ insinto /usr/include
+ doins 32bit/luise.h
+ dolib.so 32bit/libluise.so.0.1.1
+ fi
+ if use amd64 ; then
+ insinto /usr/include
+ doins 64bit/luise.h
+ newlib.so 64bit/libluise_64.so.0.1.1 libluise.so.0.1.1
+ fi
+ dosym /usr/$(get_libdir)/libluise.so{.0.1.1,}
+
+ newdoc doc/readme README
+ use doc && dodoc doc/docu_luise011_Linux.pdf
+ if use examples ; then
+ docinto examples
+ dodoc samples/luise-test/*
+ fi
+}
diff --git a/dev-libs/luise-bin/metadata.xml b/dev-libs/luise-bin/metadata.xml
new file mode 100644
index 000000000000..aba833ed90e0
--- /dev/null
+++ b/dev-libs/luise-bin/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>