summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-04 20:30:50 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-04 20:35:25 +0200
commitd114706d5e8343daf8f0273b8df61aea7ae4ca4e (patch)
tree7eda4560cd58746a8706bed0423044c9eda9fea7 /dev-libs/mm
parentnet-analyzer/nagios-check_rbl: new version 1.4.1 with perl-5.26 support. (diff)
downloadgentoo-d114706d5e8343daf8f0273b8df61aea7ae4ca4e.tar.gz
gentoo-d114706d5e8343daf8f0273b8df61aea7ae4ca4e.tar.bz2
gentoo-d114706d5e8343daf8f0273b8df61aea7ae4ca4e.zip
dev-libs/mm: eapi bump to 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-libs/mm')
-rw-r--r--dev-libs/mm/mm-1.4.2-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/mm/mm-1.4.2-r2.ebuild b/dev-libs/mm/mm-1.4.2-r2.ebuild
new file mode 100644
index 000000000000..405cb0a82e8d
--- /dev/null
+++ b/dev-libs/mm/mm-1.4.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Shared Memory Abstraction Library"
+HOMEPAGE="http://www.ossp.org/pkg/lib/mm/"
+SRC_URI="ftp://ftp.ossp.org/pkg/lib/mm/${P}.tar.gz"
+
+LICENSE="mm"
+SLOT="1.2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ sed -i Makefile.in \
+ -e '/--mode=link/s| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile.in"
+ default
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc README ChangeLog INSTALL PORTING THANKS
+}
+
+pkg_postinst() {
+ ewarn 'if you upgraded from mm-1.3 or earlier please run:'
+ ewarn "revdep-rebuild --library \"/usr/$(get_libdir)/libmm.so.13\""
+}