summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <tmozes@sygic.com>2018-10-17 10:55:05 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-26 15:17:50 +0200
commit2fc14c499be9cdc5736bfde619039b5413d6a5bc (patch)
tree8a291f3cf90ec360c0c6117706e6107c268f2e4e /dev-libs/mongo-c-driver
parentdev-db/redis: drop old (diff)
downloadgentoo-2fc14c499be9cdc5736bfde619039b5413d6a5bc.tar.gz
gentoo-2fc14c499be9cdc5736bfde619039b5413d6a5bc.tar.bz2
gentoo-2fc14c499be9cdc5736bfde619039b5413d6a5bc.zip
dev-libs/mongo-c-driver: drop tests on x86
Closes: https://bugs.gentoo.org/668288 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/mongo-c-driver')
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-0.98.2.ebuild6
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-1.1.10.ebuild6
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild6
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-1.3.5.ebuild6
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-1.6.2.ebuild6
5 files changed, 25 insertions, 5 deletions
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-0.98.2.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-0.98.2.ebuild
index c8cfa98b12d5..c5f0ca6a8576 100644
--- a/dev-libs/mongo-c-driver/mongo-c-driver-0.98.2.ebuild
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-0.98.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,6 +25,10 @@ DEPEND="${RDEPEND}
DOCS=( NEWS README.rst TUTORIAL.md )
+# No tests on x86 because tests require dev-db/mongodb which don't support
+# x86 anymore (bug #645994)
+RESTRICT="x86? ( test )"
+
src_prepare() {
# https://github.com/mongodb/mongo-c-driver/issues/54
sed -i -e "s/PTHREAD_LIBS/PTHREAD_CFLAGS/g" src/Makefile.am \
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-1.1.10.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-1.1.10.ebuild
index 270c3fa25494..2af17a8e308f 100644
--- a/dev-libs/mongo-c-driver/mongo-c-driver-1.1.10.ebuild
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-1.1.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,6 +25,10 @@ DEPEND="${RDEPEND}
DOCS=( NEWS README.rst TUTORIAL.md )
+# No tests on x86 because tests require dev-db/mongodb which don't support
+# x86 anymore (bug #645994)
+RESTRICT="x86? ( test )"
+
src_prepare() {
rm -r src/libbson || die
sed -i -e '/SUBDIRS/s:src/libbson::g' Makefile.am || die
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild
index 44af34364f24..aa9e3818623a 100644
--- a/dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,6 +25,10 @@ DEPEND="${RDEPEND}
DOCS=( NEWS README.rst TUTORIAL.md )
+# No tests on x86 because tests require dev-db/mongodb which don't support
+# x86 anymore (bug #645994)
+RESTRICT="x86? ( test )"
+
src_prepare() {
rm -r src/libbson || die
sed -i -e '/SUBDIRS/s:src/libbson::g' Makefile.am || die
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-1.3.5.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-1.3.5.ebuild
index 4ae9ba800142..90f322d03b42 100644
--- a/dev-libs/mongo-c-driver/mongo-c-driver-1.3.5.ebuild
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-1.3.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,6 +25,10 @@ DEPEND="${RDEPEND}
DOCS=( NEWS README.rst )
+# No tests on x86 because tests require dev-db/mongodb which don't support
+# x86 anymore (bug #645994)
+RESTRICT="x86? ( test )"
+
src_prepare() {
rm -r src/libbson || die
sed -i -e '/SUBDIRS/s:src/libbson::g' Makefile.am || die
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-1.6.2.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-1.6.2.ebuild
index 09d274361f4b..841127cf7d9e 100644
--- a/dev-libs/mongo-c-driver/mongo-c-driver-1.6.2.ebuild
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-1.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,6 +25,10 @@ DEPEND="${RDEPEND}
DOCS=( NEWS README.rst )
+# No tests on x86 because tests require dev-db/mongodb which don't support
+# x86 anymore (bug #645994)
+RESTRICT="x86? ( test )"
+
src_prepare() {
rm -r src/libbson || die
sed -i -e '/SUBDIRS/s:src/libbson::g' Makefile.am || die