summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-02-09 12:56:54 -0500
committerMike Frysinger <vapier@gentoo.org>2017-02-09 12:58:04 -0500
commitb47c3a358310c904284bc6fd8d6bdc87114093f9 (patch)
treefa3adbf3fd48c403f94c1a92fb201687eae055c7 /dev-libs/mpfr/mpfr-3.1.5.ebuild
parentdev-php/PEAR-Log: remove unused PEAR-Log-1.12.7-r1. (diff)
downloadgentoo-b47c3a358310c904284bc6fd8d6bdc87114093f9.tar.gz
gentoo-b47c3a358310c904284bc6fd8d6bdc87114093f9.tar.bz2
gentoo-b47c3a358310c904284bc6fd8d6bdc87114093f9.zip
dev-libs/mpfr: version bump to 3.1.5_p2 #608770
Diffstat (limited to 'dev-libs/mpfr/mpfr-3.1.5.ebuild')
-rw-r--r--dev-libs/mpfr/mpfr-3.1.5.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-libs/mpfr/mpfr-3.1.5.ebuild b/dev-libs/mpfr/mpfr-3.1.5.ebuild
deleted file mode 100644
index 7ef9311fa8e0..000000000000
--- a/dev-libs/mpfr/mpfr-3.1.5.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# NOTE: we cannot depend on autotools here starting with gcc-4.3.x
-inherit eutils libtool multilib-minimal
-
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-PLEVEL=${PV/*p}
-DESCRIPTION="library for multiple-precision floating-point computations with exact rounding"
-HOMEPAGE="http://www.mpfr.org/"
-SRC_URI="http://www.mpfr.org/mpfr-${MY_PV}/${MY_P}.tar.xz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/4" # libmpfr.so version
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="static-libs"
-
-RDEPEND=">=dev-libs/gmp-4.1.4-r2[${MULTILIB_USEDEP},static-libs?]"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- if [[ ${PLEVEL} != ${PV} ]] ; then
- local i
- for (( i = 1; i <= PLEVEL; ++i )) ; do
- epatch "${FILESDIR}"/${MY_PV}/patch$(printf '%02d' ${i})
- done
- fi
- epatch_user
- find . -type f -exec touch -r configure {} +
- elibtoolize
-}
-
-multilib_src_configure() {
- # Make sure mpfr doesn't go probing toolchains it shouldn't #476336#19
- ECONF_SOURCE=${S} \
- user_redefine_cc=yes \
- econf \
- --docdir="\$(datarootdir)/doc/${PF}" \
- $(use_enable static-libs static)
-}
-
-multilib_src_install_all() {
- use static-libs || find "${ED}"/usr -name '*.la' -delete
-
- # clean up html/license install
- pushd "${ED}"/usr/share/doc/${PF} >/dev/null || die
- dohtml *.html && rm COPYING* *.html
- popd >/dev/null || die
-}