summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-07-31 23:58:12 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-07-31 23:58:41 +0200
commit0c7fcff5968a2f03ab391467425aebf159469355 (patch)
tree474584d8f7a4e07aea770abe8d21dc341f2ac269 /dev-libs/msgpack/msgpack-2.0.0.ebuild
parentnet-im/psi: Fix copy-paste error (diff)
downloadgentoo-0c7fcff5968a2f03ab391467425aebf159469355.tar.gz
gentoo-0c7fcff5968a2f03ab391467425aebf159469355.tar.bz2
gentoo-0c7fcff5968a2f03ab391467425aebf159469355.zip
dev-libs/msgpack: version bump.
Gentoo-Bug: https://bugs.gentoo.org/601370 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-libs/msgpack/msgpack-2.0.0.ebuild')
-rw-r--r--dev-libs/msgpack/msgpack-2.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/msgpack/msgpack-2.0.0.ebuild b/dev-libs/msgpack/msgpack-2.0.0.ebuild
new file mode 100644
index 000000000000..fa3087187ed3
--- /dev/null
+++ b/dev-libs/msgpack/msgpack-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}-c.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}-c/releases/download/cpp-${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
+HOMEPAGE="http://msgpack.org/ https://github.com/msgpack/msgpack-c/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+cxx static-libs test"
+
+DEPEND="
+ test? (
+ >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ )
+"
+
+DOCS=( README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DMSGPACK_ENABLE_CXX=$(usex cxx)
+ -DMSGPACK_STATIC=$(usex static-libs)
+ )
+
+ cmake-multilib_src_configure
+}