summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-12-11 18:34:17 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-12-11 18:35:37 +0200
commitfd260f28a07b3a7c5c86e538fa46dded3454747e (patch)
treecf5ffe7d1ab1f9be55ededce4658899ae3674313 /dev-libs/nettle
parentapp-crypt/tpm-emulator: allow fallthrough (diff)
downloadgentoo-fd260f28a07b3a7c5c86e538fa46dded3454747e.tar.gz
gentoo-fd260f28a07b3a7c5c86e538fa46dded3454747e.tar.bz2
gentoo-fd260f28a07b3a7c5c86e538fa46dded3454747e.zip
dev-libs/nettle: version bump
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=640704 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-libs/nettle')
-rw-r--r--dev-libs/nettle/Manifest1
-rw-r--r--dev-libs/nettle/nettle-3.4.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/nettle/Manifest b/dev-libs/nettle/Manifest
index 05a136ab7e7a..2dbf9cd3960b 100644
--- a/dev-libs/nettle/Manifest
+++ b/dev-libs/nettle/Manifest
@@ -1 +1,2 @@
DIST nettle-3.3.tar.gz 1887927 BLAKE2B 4bcf3c4bfb9f9dae97ea6780d146f3313e8b51182d9942e69581428d9f602d16467d37f993700a4e94e2e0dee17bdf354694c94d0383164c3de6e57e7e24de4e SHA512 271981d89766f151af3cdc4e5fc43c438222f0f6f44475bad114f4209955b5235fced6526c7abca001cca223e8cfcd2a6bf389b160b305a499e7acf52425ec70
+DIST nettle-3.4.tar.gz 1935069 BLAKE2B b73c88236c8233360607a6ed65cd4f6d19bfbbf683b46149326ce3440bf0a42b8add69de5c64145720163b1095fdab3cb8bf410c2ef727d0ea4fb58391ff0f14 SHA512 3bea3aabd2c99cc42d084a94fd6b0b5dbdb24cd6c7020271a6ee87a81a904b21b21756f590cb1afdf2e85fd1cb59e5c3651c5c4032e30204e7ea6f8801d1ea3b
diff --git a/dev-libs/nettle/nettle-3.4.ebuild b/dev-libs/nettle/nettle-3.4.ebuild
new file mode 100644
index 000000000000..928df9048198
--- /dev/null
+++ b/dev-libs/nettle/nettle-3.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-build multilib-minimal multilib toolchain-funcs
+
+DESCRIPTION="Low-level cryptographic library"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="https://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 LGPL-2.1 )"
+SLOT="0/6.2" # subslot = libnettle soname version, .2 as broke ABI bug#601512 then fixed
+KEYWORDS=""
+IUSE="doc +gmp neon static-libs test cpu_flags_x86_aes"
+
+DEPEND="gmp? ( >=dev-libs/gmp-5.0:0=[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20131008-r17
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/nettle/nettle-stdint.h
+ /usr/include/nettle/version.h
+)
+
+DOCS=()
+HTML_DOCS=()
+
+S="${WORKDIR}/${PN}-3.4"
+
+pkg_setup() {
+ use doc && DOCS+=(
+ nettle.pdf
+ )
+ use doc && HTML_DOCS+=(
+ nettle.html
+ )
+}
+
+src_prepare() {
+ default
+
+ sed -e '/CFLAGS=/s: -ggdb3::' \
+ -e 's/solaris\*)/sunldsolaris*)/' \
+ -i configure.ac || die
+
+ # conditionally build tests and examples required by tests
+ use test || sed -i '/SUBDIRS/s/testsuite examples//' Makefile.in || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # --disable-openssl bug #427526
+ ECONF_SOURCE="${S}" econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --disable-openssl \
+ --disable-fat \
+ $(use_enable gmp public-key) \
+ $(use_enable static-libs static) \
+ $(tc-is-static-only && echo --disable-shared) \
+ $(use_enable doc documentation) \
+ $(use_enable neon arm-neon) \
+ $(use_enable cpu_flags_x86_aes x86-aesni)
+}