summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-12-06 20:10:00 +0000
committerMike Gilbert <floppym@gentoo.org>2019-12-06 15:24:38 -0500
commit15011d6eb9260283b3ad89e729096659cddb0caa (patch)
treec8f13ad99d80b0c701db0f37e645ac49f7a48cf1 /dev-libs/oniguruma
parentdev-libs/oniguruma: Minor fixes. (diff)
downloadgentoo-15011d6eb9260283b3ad89e729096659cddb0caa.tar.gz
gentoo-15011d6eb9260283b3ad89e729096659cddb0caa.tar.bz2
gentoo-15011d6eb9260283b3ad89e729096659cddb0caa.zip
dev-libs/oniguruma: Add live ebuild.
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs/oniguruma')
-rw-r--r--dev-libs/oniguruma/oniguruma-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/oniguruma/oniguruma-9999.ebuild b/dev-libs/oniguruma/oniguruma-9999.ebuild
new file mode 100644
index 000000000000..8efae9394402
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2003-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit autotools git-r3
+
+ EGIT_REPO_URI="https://github.com/kkos/oniguruma"
+fi
+
+DESCRIPTION="Regular expression library for different character encodings"
+HOMEPAGE="https://github.com/kkos/oniguruma"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/onig-${PV}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0/5"
+KEYWORDS=""
+IUSE="crnl-as-line-terminator static-libs"
+
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/onig-${PV}"
+fi
+
+DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES})
+
+src_prepare() {
+ default
+
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable crnl-as-line-terminator) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name "*.la" -type f -delete || die
+}