summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-07 00:36:03 +0000
committerSam James <sam@gentoo.org>2020-11-07 00:48:47 +0000
commitc01a70bc4a6beb35a9abd6f23bc6da671c6d931b (patch)
treec9383e337861e402d31b9c06d00442f53c4bb845 /dev-libs/oniguruma
parentnet-p2p/syncthing: Stabilize 1.10.0 amd64, #752381 (diff)
downloadgentoo-c01a70bc4a6beb35a9abd6f23bc6da671c6d931b.tar.gz
gentoo-c01a70bc4a6beb35a9abd6f23bc6da671c6d931b.tar.bz2
gentoo-c01a70bc4a6beb35a9abd6f23bc6da671c6d931b.zip
dev-libs/oniguruma: bump to 6.9.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/oniguruma')
-rw-r--r--dev-libs/oniguruma/Manifest1
-rw-r--r--dev-libs/oniguruma/oniguruma-6.9.6.ebuild43
-rw-r--r--dev-libs/oniguruma/oniguruma-9999.ebuild23
3 files changed, 52 insertions, 15 deletions
diff --git a/dev-libs/oniguruma/Manifest b/dev-libs/oniguruma/Manifest
index 78f1b0aef45e..05a244cee064 100644
--- a/dev-libs/oniguruma/Manifest
+++ b/dev-libs/oniguruma/Manifest
@@ -1 +1,2 @@
DIST onig-6.9.4.tar.gz 908702 BLAKE2B e6e9939f284569408ba01b8551960bc939bbfdca425f8470499f5bb83ead7b6b09898f6f6a09d5d8c26d74d5416f6e5e9e2f00fbe7aa9eb820edb8aa4a3050cc SHA512 ed8f42f6893966c0ee3c168b4fdbcb04b2286ad69ecab43a754c1dbc8fc4656e01319991d776d7144b6a3f90d050781b321432278d83c74c9565c2743851c85b
+DIST onig-6.9.6.tar.gz 926459 BLAKE2B 7a5fb49b35abe11fb91e7e4529855411fa0eb357897a2b327ddb5696a2c1e5f9fe7eb653fe84dbaeeff9c77e5489fd042d65e84f5b8e3e907bd30d60a0b75914 SHA512 eb44f70347f49945fe054ad65370dbfd6b30b2e8442fb90b6c72413b7f9a8cb77ca98d1a4714d1d32b763551430436cc0175c0efaf2c73268363a9b6ecb5e3bc
diff --git a/dev-libs/oniguruma/oniguruma-6.9.6.ebuild b/dev-libs/oniguruma/oniguruma-6.9.6.ebuild
new file mode 100644
index 000000000000..4c0eebf2c0ca
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-6.9.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2003-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/kkos/oniguruma"
+else
+ SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/onig-${PV}.tar.gz"
+ S="${WORKDIR}/onig-${PV}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+fi
+
+DESCRIPTION="Regular expression library for different character encodings"
+HOMEPAGE="https://github.com/kkos/oniguruma"
+
+LICENSE="BSD-2"
+SLOT="0/5"
+IUSE="crnl-as-line-terminator static-libs"
+
+DOCS=( AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES} )
+
+src_prepare() {
+ default
+
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable crnl-as-line-terminator) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name "*.la" -type f -delete || die
+}
diff --git a/dev-libs/oniguruma/oniguruma-9999.ebuild b/dev-libs/oniguruma/oniguruma-9999.ebuild
index 8efae9394402..4c0eebf2c0ca 100644
--- a/dev-libs/oniguruma/oniguruma-9999.ebuild
+++ b/dev-libs/oniguruma/oniguruma-9999.ebuild
@@ -1,34 +1,27 @@
-# Copyright 2003-2019 Gentoo Authors
+# Copyright 2003-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
inherit multilib-minimal
if [[ "${PV}" == "9999" ]]; then
inherit autotools git-r3
-
EGIT_REPO_URI="https://github.com/kkos/oniguruma"
+else
+ SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/onig-${PV}.tar.gz"
+ S="${WORKDIR}/onig-${PV}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
fi
DESCRIPTION="Regular expression library for different character encodings"
HOMEPAGE="https://github.com/kkos/oniguruma"
-if [[ "${PV}" == "9999" ]]; then
- SRC_URI=""
-else
- SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/onig-${PV}.tar.gz"
-fi
LICENSE="BSD-2"
SLOT="0/5"
-KEYWORDS=""
IUSE="crnl-as-line-terminator static-libs"
-if [[ "${PV}" != "9999" ]]; then
- S="${WORKDIR}/onig-${PV}"
-fi
-
-DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES})
+DOCS=( AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES} )
src_prepare() {
default
@@ -46,5 +39,5 @@ multilib_src_configure() {
multilib_src_install_all() {
einstalldocs
- find "${D}" -name "*.la" -type f -delete || die
+ find "${ED}" -name "*.la" -type f -delete || die
}