summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-12-16 02:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-12-27 13:39:07 -0500
commitdb427c54c0a8b7423640983e520cc3c13903f8cc (patch)
tree608a21d3d5bb28d10ccc626a1d5d7c55736562d0 /dev-libs/oniguruma
parentdev-java/protobuf-java: Delete old version (3.11.4). (diff)
downloadgentoo-db427c54c0a8b7423640983e520cc3c13903f8cc.tar.gz
gentoo-db427c54c0a8b7423640983e520cc3c13903f8cc.tar.bz2
gentoo-db427c54c0a8b7423640983e520cc3c13903f8cc.zip
dev-libs/oniguruma: Synchronize ebuilds.
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs/oniguruma')
-rw-r--r--dev-libs/oniguruma/oniguruma-9999.ebuild26
1 files changed, 19 insertions, 7 deletions
diff --git a/dev-libs/oniguruma/oniguruma-9999.ebuild b/dev-libs/oniguruma/oniguruma-9999.ebuild
index 4c0eebf2c0ca..405b066a532a 100644
--- a/dev-libs/oniguruma/oniguruma-9999.ebuild
+++ b/dev-libs/oniguruma/oniguruma-9999.ebuild
@@ -1,27 +1,38 @@
# Copyright 2003-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="7"
inherit multilib-minimal
if [[ "${PV}" == "9999" ]]; then
inherit autotools git-r3
+
EGIT_REPO_URI="https://github.com/kkos/oniguruma"
-else
- SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/onig-${PV}.tar.gz"
- S="${WORKDIR}/onig-${PV}"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
fi
DESCRIPTION="Regular expression library for different character encodings"
HOMEPAGE="https://github.com/kkos/oniguruma"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/onig-${PV}.tar.gz"
+fi
LICENSE="BSD-2"
SLOT="0/5"
+KEYWORDS=""
IUSE="crnl-as-line-terminator static-libs"
-DOCS=( AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES} )
+BDEPEND=""
+DEPEND=""
+RDEPEND=""
+
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/onig-${PV}"
+fi
+
+DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES})
src_prepare() {
default
@@ -33,11 +44,12 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
+ --enable-posix-api \
$(use_enable crnl-as-line-terminator) \
$(use_enable static-libs static)
}
multilib_src_install_all() {
einstalldocs
- find "${ED}" -name "*.la" -type f -delete || die
+ find "${ED}" -name "*.la" -delete || die
}